vchepkov
03/09/2023, 8:11 PMvchepkov
03/09/2023, 8:12 PMSlackbot
03/09/2023, 8:36 PMwil.rodriguez
03/09/2023, 8:48 PMpuppetdb ssl-setup command, which fixed the ssl errors. I now get this error:
2023-03-09T14:44:15.710-06:00 ERROR [p.t.internal] Error during service start!!!
org.bouncycastle.openssl.PEMException: unable to convert key pair: RSA KeyFactory not available
...
Caused by: java.security.NoSuchAlgorithmException: RSA KeyFactory not available
...
Even using your code, I couldn't get it to work. I'm wondering if it has something to do with my system being DISA STIG hardened... I might see if I can try the same code on a system that's not hardened.wil.rodriguez
03/09/2023, 8:49 PMpuppetdb ssl-setup command, which fixed the ssl errors. I now get this error:
2023-03-09T14:44:15.710-06:00 ERROR [p.t.internal] Error during service start!!!
org.bouncycastle.openssl.PEMException: unable to convert key pair: RSA KeyFactory not available
...
Caused by: java.security.NoSuchAlgorithmException: RSA KeyFactory not available
...
Even using your code, I couldn't get it to work. I even fully uninstalled and reinstalled and got to the exact same error (after fixing a bunch of file permissions resulting from my restrictive umask). I'm wondering if it has something to do with my system being DISA STIG hardened... I might see if I can try the same code on a system that's not hardened.Dr Bunsen Honeydew
03/09/2023, 9:45 PMziggy
03/09/2023, 10:18 PM. except to for the very last one?
e.g $host = puppet.domain.internal.crt
.crt I want to keep. I want to replace . for everything else to get puppet_domain_internal.crt
something like regsubstr($host, '[.]', '_', G), but obviously that isnt right.kenyon
03/09/2023, 10:23 PMziggy
03/09/2023, 10:28 PMziggy
03/09/2023, 10:28 PMziggy
03/09/2023, 10:29 PMziggy
03/09/2023, 10:29 PMziggy
03/09/2023, 10:31 PMkenyon
03/09/2023, 10:32 PM.crt, regsubst the first part, then put the .crt back onziggy
03/09/2023, 10:56 PMziggy
03/09/2023, 10:56 PMnatemccurdy
03/09/2023, 10:58 PMziggy
03/09/2023, 10:59 PMziggy
03/09/2023, 10:59 PMSlackbot
03/10/2023, 7:25 AMbrokencode
03/10/2023, 7:25 AMfrontend stats
bind *:8404
mode http
stats refresh 10s
stats enable
stats uri /stats
Looking at the module's frontend manifest and template, there seems to only exists an option to pass hash values for extra options and since there is the same key in my case, only the last option gets an entry.
How are you solving this problem?
Module: https://github.com/puppetlabs/puppetlabs-haproxybrokencode
03/10/2023, 7:26 AMSlackbot
03/10/2023, 4:44 PMSlackbot
03/10/2023, 5:12 PMLes Shiner
03/10/2023, 5:43 PMkenyon
03/10/2023, 7:05 PMredat
03/10/2023, 9:26 PMr10k deploy environment -c /etc/puppetlabs/r10k.yaml
It does work as intended, meaning that when this command is run, folders are created corresponding to the differents branch on the git repository :
root@puppet:/etc/puppetlabs/code# ls
production testing
However, I have this error with puppet agent :
puppet agent --environment=testing --test --noop
Info: Using environment 'testing'
Notice: Environment 'testing' not found on server, skipping initial pluginsync.
Notice: Local environment: 'testing' doesn't match server specified environment 'production', restarting agent run with environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Applying configuration version '1678314056'
Notice: Applied catalog in 0.02 seconds
If someone could tell me what I might be missing, or point me in the good direction, thanks in advance !redat
03/10/2023, 9:27 PMr10k deploy environment -c /etc/puppetlabs/r10k.yaml
It does work as intended, meaning that when this command is run, folders are created corresponding to the differents branch on the git repository :
root@puppet:/etc/puppetlabs/code# ls
production testing
However, I have this error with puppet agent :
puppet agent --environment=testing --test --noop
Info: Using environment 'testing'
Notice: Environment 'testing' not found on server, skipping initial pluginsync.
Notice: Local environment: 'testing' doesn't match server specified environment 'production', restarting agent run with environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Applying configuration version '1678314056'
Notice: Applied catalog in 0.02 seconds
If someone could tell me what I might be missing, or point me in the good direction, thanks in advance !Slackbot
03/10/2023, 9:29 PMSlackbot
03/10/2023, 11:50 PM