vchepkov
01/26/2023, 6:40 PMvchepkov
01/26/2023, 6:40 PMChris Lee
01/26/2023, 6:54 PMvchepkov
01/26/2023, 7:27 PMSlackbot
01/26/2023, 7:27 PMnatemccurdy
01/26/2023, 8:15 PMsprintf() method has a problem in that in only adds padding if the value is longer than the specified pad length. Use Henrik's string slicing solution instead to always add the padding.
For example:
$ puppet apply slack.pp
Notice: Scope(Class[main]): hello world
Notice: Scope(Class[main]): hello world
Notice: Scope(Class[main]): length of lots_of_spaces: 100
Notice: Scope(Class[main]): hello worldchadh
01/26/2023, 8:54 PMnatemccurdy
01/26/2023, 8:56 PMnatemccurdy
01/26/2023, 8:56 PMbastelfreak
01/26/2023, 9:04 PMcsharpsteen
01/26/2023, 9:08 PMOpenSSL::PKCS7 didn't understand anything stronger than CBC (e.g. GCM). If that's still the case, patches need to go to Ruby its self 😉csharpsteen
01/26/2023, 9:09 PMcsharpsteen
01/26/2023, 9:09 PMcsharpsteen
01/26/2023, 9:10 PMnotice() to a manifest that logs out the decrypted value.
Or worse.csharpsteen
01/26/2023, 9:11 PMnotice() to a manifest that logs out the decrypted value.
Or worse.Ken
01/26/2023, 9:39 PMKen
01/26/2023, 9:40 PMKen
01/26/2023, 9:41 PMvchepkov
01/26/2023, 9:41 PMvchepkov
01/26/2023, 9:42 PMSlackbot
01/26/2023, 9:42 PMDr Bunsen Honeydew
01/26/2023, 9:42 PMtheforeman-puppet module at https://forge.puppet.com/theforeman/puppet?src=slack&channel=puppetKen
01/26/2023, 9:44 PMDr Bunsen Honeydew
01/26/2023, 9:45 PMKen
01/26/2023, 9:45 PMCVQuesty
01/26/2023, 9:52 PMCVQuesty
01/26/2023, 9:53 PMLes Shiner
01/26/2023, 10:17 PM-- Logs begin at Thu 2023-01-26 21:25:38 UTC, end at Thu 2023-01-26 22:14:57 UTC. --
Jan 26 22:10:05 Compiler-1 puppetserver[231512]: Execution error (IllegalArgumentException) at puppetlabs.trapperkeeper.services.webserver.jetty9-config/fn$get-x509s-from-ssl-cert-pem$fn (jetty9_config.clj:246).
Jan 26 22:10:05 Compiler-1 puppetserver[231512]: Unable to open 'ssl-cert' file: /etc/puppetlabs/puppet/ssl/certs/master.ksmxe13yf34ergehjclg4kj1vh.bx.internal.cloudapp.net.pem
Jan 26 22:10:05 Compiler-1 puppetserver[231512]: Full report at:
Jan 26 22:10:05 Compiler-1 puppetserver[231512]: /tmp/clojure-2800691518232323941.edn
Jan 26 22:10:06 Compiler-1 puppetserver[231484]: Background process 231512 exited before start had completed
Jan 26 22:10:06 Compiler-1 systemd[1]: puppetserver.service: Control process exited, code=exited, status=1/FAILURE
Jan 26 22:10:06 Compiler-1 systemd[1]: puppetserver.service: Failed with result 'exit-code'.
Jan 26 22:10:06 Compiler-1 systemd[1]: Failed to start puppetserver Service.
Jan 26 22:10:06 Compiler-1 systemd[1]: puppetserver.service: Scheduled restart job, restart counter is at 533.
On my compiler I'm getting this error when it's trying to start puppetdb. This cert doesn't exist on the system. I have
puppetdb::database_host: '<http://master.ksmxe13yf34ergehjclg4kj1vh.bx.internal.cloudapp.net|master.ksmxe13yf34ergehjclg4kj1vh.bx.internal.cloudapp.net>'
set for the compiler.
Any suggestions?Dr Bunsen Honeydew
01/26/2023, 10:17 PMLes Shiner
01/26/2023, 10:19 PM-- Logs begin at Thu 2023-01-26 21:25:38 UTC, end at Thu 2023-01-26 22:14:57 UTC. --
Jan 26 22:10:05 Compiler-1 puppetserver[231512]: Execution error (IllegalArgumentException) at puppetlabs.trapperkeeper.services.webserver.jetty9-config/fn$get-x509s-from-ssl-cert-pem$fn (jetty9_config.clj:246).
Jan 26 22:10:05 Compiler-1 puppetserver[231512]: Unable to open 'ssl-cert' file: /etc/puppetlabs/puppet/ssl/certs/master.ksmxe13yf34ergehjclg4kj1vh.bx.internal.cloudapp.net.pem
Jan 26 22:10:05 Compiler-1 puppetserver[231512]: Full report at:
Jan 26 22:10:05 Compiler-1 puppetserver[231512]: /tmp/clojure-2800691518232323941.edn
Jan 26 22:10:06 Compiler-1 puppetserver[231484]: Background process 231512 exited before start had completed
Jan 26 22:10:06 Compiler-1 systemd[1]: puppetserver.service: Control process exited, code=exited, status=1/FAILURE
Jan 26 22:10:06 Compiler-1 systemd[1]: puppetserver.service: Failed with result 'exit-code'.
Jan 26 22:10:06 Compiler-1 systemd[1]: Failed to start puppetserver Service.
Jan 26 22:10:06 Compiler-1 systemd[1]: puppetserver.service: Scheduled restart job, restart counter is at 533.
On my compiler I'm getting this error when it's trying to start puppetdb. This cert doesn't exist on the system. I have
puppetdb::database_host: '<http://master.ksmxe13yf34ergehjclg4kj1vh.bx.internal.cloudapp.net|master.ksmxe13yf34ergehjclg4kj1vh.bx.internal.cloudapp.net>'
set for the compiler.
Any suggestions?