This message was deleted.
# citrix-app-layering
s
This message was deleted.
r
Is this after installing the app and rebooting?
j
We see the error right after a new AppLayer is created. Platform and OS layer are booting just fine.
and we ran the Citrix App Layering preparation script from George Spiers on the OS Layer with the updated ngen recommendation.
In the meantime, I suggested to the customer to start by updating ELM, the OS Layer with the latest AppLayering Tools and then try a new app layer again.
r
Its probably something weird the install is doing nothing in a tools update woudl matter its just scripts
So you get this during packaging or on a vda when booting?
j
booting the packaging vm with a new app layer
r
BTW we changed our recommendations on running ngen and we recommend you run ngen eqi 3 rather than ngen update. I imagein Georges script has ngen update. But i also doubt that woud be the cause of this. He does run some dism commands that could cause issues in some cases,
Is this win11?
j
Server 2019
yeah we ran ngen eqi 3, if you look on George Spiers blog I recommended he update his script with the newer ngen recommendation 😄 @George Spiers it would be nice if you could modify the ngen command. Thanks!
r
And was it on a packaging machine or the vda when booting
j
packaging
r
The recommendation from engineering was try again with a new layer. If that fails again try it without connector caching enabled.
j
a new app layer ? we did that already. Or are you talking about a new OS layer ?
r
No just a new app layer. Do you use caching in your connector? If so try without that. You can either create a new connector with it disabled or set it to 0.
j
I'm pretty sure we have it enabled, we will test without it, thanks