Anyone running Server 2025 VDAs in App Layering (2...
# citrix-app-layering
n
Anyone running Server 2025 VDAs in App Layering (2503)? Booted my first provisioned VDA this morning in vSphere, and it's basically stuck in a reboot loop. Boots, gets to 'Getting devices ready', reboots.
Switching the vDisk to Private Mode boots, so it has to be installing something... just no idea what.
r
I have it in 2507 works fine
n
Just built a brand new Platform layer with 2507, same issue. Testing 2402 CU3 now just for posterity.
And the same with 2402 CU3. Guess I'm booting into Private mode again to see if anything jumps out at me.
lol, which it boots up to right away.
r
No 2507
n
no 2507...?
I meant VDA 2057 LTSR/PVS 2507 LTSR. ELM is still 2503
Seeing a lot of bnistack events in the log
The others are 'failed to connect to the server pausing before retry'
lol, one of the images booted on another hypervisor, but not before a "sign-in process initialization failed" error on the first boot, causing it to shut down.
image.png
Rob, you have any thoughts on the VMware template? We changed ours so many times, and I don't know if that's contributing to any of this. I would normally build the template, use that for the layers and PVS target devices, and would migrate/clone the template to other vCenters for building on them. Any reason new templates with the same settings can't be used on those other hypervisors?
r
Only if the hw version is not supported
You removed the disk correct?
n
Yep
HW version is 8.0 U2 on all of htem
r
Should work fine then using the same template.
n
For your S25 stuff, do you have Secure Boot enabled? If so, do you also have it enabled for your S25 template for your App Layering packaging machines?
r
Yes I have secure boot enable on my template and i se the template in my connectors so all the machines created wiht it have secure boot enabled. I also do everything now in efi. I dont have a tpm for it though.
n
I have no idea if this is part of my issue, but any issue with me modifying the template to enable Secure Boot? Would I need to rebuild those layers?
r
I dont think so
just republish
yoiu also have to enable it on any vdas you have created
n
This error on the first boot of all of my S25 images when creating new target devices is driving me insane
r
what vda are you using
n
2507 LTSR
Saw the same issue on 2402 CU3
r
k
thsi si pvs?
n
Yep
My Azure Platform layer and image work fine, though.
So it's just on-prem/VMware
r
have you tried recreatnig the platform alyer
since that s whats diferent
n
like 5 times
r
what happens if you dont include any layers
but the platform alyer
n
I just noticed that the PVS connector I used is using a different vCenter than the target. No idea if that changes things, but I have to fix it.
I've tried that, still has the issue.
r
k
n
I think I've done all of the basics at this point
r
can you log in on the console
or via rdp
n
Never gets to the point of being able to login. Goes from getting devices ready to that error. Click okay and it shuts down
r
what if you onnect ot the event viewer before clikcing can you see if some services have failed
sounds to me like you should start over wiht a new gold image
was this creaed on vmware to start wiht
n
Yes, it was
By myself
so I know it was done right. 🙂
r
i have never seen yhat one beore but there are a few hits for it over the years not on 2025
in google that is
n
Yeah, and every thread in the old Citrix forums went unanswered
Compiling a new image using a Secure Boot template now just to see what it does. Also building another Platform layer for the other domain. If all of this fails, I will start with a fresh OS import.
I have never had these issues with any previous OS, and it's making me hate PVS.
r
what version of pvs BTW
n
2507
r
make sur you are using 2507.1
but that will eb a licneinsg error
not what you are seeing
n
lol, they will be thrilled to hear that
r
yea theres a prpoblek wiht licnensieng based on the las chnages
so you need to se the .1
n
go enjoy your saturday. misery doesn't need company when you help out enough, lol
r
ha
good luck
n
I don't need luck, just a big fuckin hammer
r
lol
not allowed to hit people wiht hammers you know
n
disappointed
Same error on the Secure Boot image. Guess I'm redoing it all.
Same error with a Platform layer on the legacy domain, too. Last test will be a core Platform layer with just the VDA and PVS, no other changes.
r
Very weird
n
Yep. All tests failed, so I'm going to just redo it all, starting with a new OS build.
Brand new everything, similar result. First boot goes from the Windows boot screen at 'Getting devices ready' with the spinning circle to 'Getting ready' to a black screen, to a LogonUI.exe failure... VM shuts down.
2nd boot is fine. I don't get it.
r
are you building the os or taking a coprorate image
When you say second boot is fine to you mean if the first boot is into private mofde then you save the chnages
are you sure the hardware is the same between your packaging and publcihing
Shoudl eb if yo are usingt the same vm template
n
Yep, when I recreated everything, I used the same template for both App Layering connectors and the PVS wizard for target device creation.
r
is the hardware version the same for sure
n
When I built the S25 VM to install the OS, it had a CD-ROM drive for the ISO. Installed the OS, removed the device, then finished the OS build (.NET install, app layering agent, etc.). Imported the OS into the ELM, shut down the VM. Cloned it, removed the hard disk device, converted to template.
Yes, 8.0 U2 or later
r
no idea then is crowdstrike installed
n
Nope, this is just OS, Platform, O365, and Teams. Same happens with just OS and Platform.
r
is the os patched
n
Yep, latest patches installed.
And using the latest VMware Tools (13.0.5)
r
you can look in the setupapidev.log file to see whats changing to make it do the getting devices ready
n
can do
lol, and a new error on another test
r
never seen that before
n
I see nothing for that initial boot where it screws up. The next boot, I see a Sysprep Respecialize section that runs through a bunch of stuff. Looks like just configuration stuff. Then a delete device (uniservice.exe -R), a device install for upmaction.inf, and another device install for upmjit.inf
UPMACTION Mini-Filter Driver and UPMJIT Mini-Filter Driver
r
you arent telling it to sysprep are you
n
Nope
r
i wonder if you rebooted enough after isntalling upm
n
the VDA took like 4 reboots, and I had at least 4 more reboots for other installs afterwards
r
well tthats certainly enough
n
Had the same issue with 2402 CU2 for the VDA/PVS, as well
FWIW, also never see any sysprep option in the PVS wizard. Never have, really.
r
pvs doesnt syspre
but if the image was set to sysprep it woudl cause all kinds of issues
double check your connector config
n
I'm definitely not running sysprep with anything
r
there is an option for sysprep
n
I don't see a sysprep option in the connector?
You mean the template?
Template has Not Generalized (only option) selected.
r
k
I have no more ideas
n
scream into the void?
I appreciate all the help regardless
r
can you give me your setupapidev log
ill ask the engineers to look at it
ill also check mine for that uniservice entry
n
sent
(e-mail)
r
got it thanks
n
Guess I'll be building a Platform layer without CPM now. Just don't see that being the issue, as I saw this on 2402, as well. The common denominator is the OS.