https://www.puppet.com/community logo
Join Slack
Powered by
# puppet
  • p

    P. Aiello

    12/20/2022, 2:56 PM
    For those that are interested, the discussion about Advents of Code has a lot of snippets, especially those from @helindbe, that can be useful as starting point for bigger things. https://github.com/puppetlabs/community/discussions/28
  • c

    csharpsteen

    12/20/2022, 3:08 PM
    So, im most cases, the answer to "how do I use eyaml with Deferred?" is "you don't." ๐Ÿ˜‰
  • c

    csharpsteen

    12/20/2022, 3:08 PM
    So, in most cases, the answer to "how do I use eyaml with Deferred?" is "you don't." ๐Ÿ˜‰
  • s

    Slackbot

    12/20/2022, 5:12 PM
    This message was deleted.
    b
    c
    e
    • 4
    • 11
  • d

    Dr Bunsen Honeydew

    12/20/2022, 5:45 PM
    waiting ๐Ÿง‘โ€๐ŸซPuppet Core Team is about to start up in #CFD8Z9A4T
  • b

    binford2k

    12/20/2022, 7:37 PM
    I wouldn't say that my use is tested, but I have installed and played with Puppet 7 on Ruby 3.2.
  • s

    Slackbot

    12/20/2022, 10:26 PM
    This message was deleted.
    w
    • 2
    • 1
  • h

    hbui

    12/20/2022, 10:27 PM
    show_diff => false is always fine
  • h

    hbui

    12/20/2022, 10:27 PM
    Sensitive requires some extra work, both can co-exist
  • h

    hbui

    12/20/2022, 10:29 PM
    this is the reference I have for dealing with sensitive data: https://puppet.com/blog/my-journey-securing-sensitive-data-puppet-code/ though there was some discussion recently about using vault and deferred as a better solution (the blog article is 4 yrs old now)
  • y

    Yury Bushmelev

    12/21/2022, 6:05 AM
    โ„น๏ธ JFYI if youโ€™re using Hashicorp Vault as a PKI please have a look on my recently released
    vaultbot
    module: https://forge.puppet.com/modules/jay7x/vaultbot
    โค๏ธ 1
    ๐Ÿ‘ 1
    ๐Ÿฆœ 1
  • s

    Slackbot

    12/21/2022, 12:35 PM
    This message was deleted.
    t
    c
    h
    • 4
    • 3
  • s

    Slackbot

    12/21/2022, 3:17 PM
    This message was deleted.
    h
    c
    +2
    • 5
    • 35
  • c

    Callum McCrorie

    12/21/2022, 3:17 PM
    Hi All, I am hoping that someone might be able to help me out with an
    nginx
    issue that I am facing. I have seen there was a issue that was opened here: https://github.com/voxpupuli/puppet-nginx/issues/1372 I am currently running
    ubuntu 20.4
    on my server and
    ubuntu 22.04
    on my agent. The error that I am seeing is:
    Copy code
    Notice: /Stage[main]/Profiles::Letsencrypt/Letsencrypt::Certonly[*.<http://test.name.com|test.name.com>]/Cron[letsencrypt renew cron *.<http://test.name.com|test.name.com>]/ensure: created
    Error: Systemd start for nginx failed!
    journalctl log for nginx:
    Dec 21 14:34:57 eb-web systemd[1]: Starting nginx - high performance web server...
    Dec 21 14:34:57 eb-web nginx[2398700]: nginx: [emerg] open() "/etc/letsencrypt/options-ssl-nginx.conf" failed (2: No such file or directory) in /etc/nginx/sites-enabled/www.test.name.com.conf:37
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Failed with result 'exit-code'.
    Dec 21 14:34:57 eb-web systemd[1]: Failed to start nginx - high performance web server.
    
    Error: /Stage[main]/Nginx::Service/Service[nginx]/ensure: change from 'stopped' to 'running' failed: Systemd start for nginx failed!
    journalctl log for nginx:
    Dec 21 14:34:57 eb-web systemd[1]: Starting nginx - high performance web server...
    Dec 21 14:34:57 eb-web nginx[2398700]: nginx: [emerg] open() "/etc/letsencrypt/options-ssl-nginx.conf" failed (2: No such file or directory) in /etc/nginx/sites-enabled/www.test.name.com.conf:37
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Failed with result 'exit-code'.
    Dec 21 14:34:57 eb-web systemd[1]: Failed to start nginx - high performance web server.
  • c

    Callum McCrorie

    12/21/2022, 3:17 PM
    Hi All, I am hoping that someone might be able to help me out with an
    nginx
    issue that I am facing. I have seen there was a issue that was opened here: https://github.com/voxpupuli/puppet-nginx/issues/1372 I am currently running
    ubuntu 20.4
    on my server and
    ubuntu 22.04
    on my agent. The error that I am seeing is:
    Copy code
    Notice: /Stage[main]/Profiles::Letsencrypt/Letsencrypt::Certonly[*.<http://test.name.com|test.name.com>]/Cron[letsencrypt renew cron *.<http://test.name.com|test.name.com>]/ensure: created
    Error: Systemd start for nginx failed!
    journalctl log for nginx:
    Dec 21 14:34:57 eb-web systemd[1]: Starting nginx - high performance web server...
    Dec 21 14:34:57 eb-web nginx[2398700]: nginx: [emerg] open() "/etc/letsencrypt/options-ssl-nginx.conf" failed (2: No such file or directory) in /etc/nginx/sites-enabled/www.test.name.com.conf:37
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Failed with result 'exit-code'.
    Dec 21 14:34:57 eb-web systemd[1]: Failed to start nginx - high performance web server.
    
    Error: /Stage[main]/Nginx::Service/Service[nginx]/ensure: change from 'stopped' to 'running' failed: Systemd start for nginx failed!
    journalctl log for nginx:
    Dec 21 14:34:57 eb-web systemd[1]: Starting nginx - high performance web server...
    Dec 21 14:34:57 eb-web nginx[2398700]: nginx: [emerg] open() "/etc/letsencrypt/options-ssl-nginx.conf" failed (2: No such file or directory) in /etc/nginx/sites-enabled/www.test.name.com.conf:37
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Failed with result 'exit-code'.
    Dec 21 14:34:57 eb-web systemd[1]: Failed to start nginx - high performance web server.
    Thank you.
  • c

    Callum McCrorie

    12/21/2022, 3:18 PM
    Hi All, I am hoping that someone might be able to help me out with an
    nginx
    issue that I am facing. I have seen there was a issue that was opened here: https://github.com/voxpupuli/puppet-nginx/issues/1372 I am currently running
    ubuntu 20.04
    on my server and
    ubuntu 22.04
    on my agent. The error that I am seeing is:
    Copy code
    Notice: /Stage[main]/Profiles::Letsencrypt/Letsencrypt::Certonly[*.<http://test.name.com|test.name.com>]/Cron[letsencrypt renew cron *.<http://test.name.com|test.name.com>]/ensure: created
    Error: Systemd start for nginx failed!
    journalctl log for nginx:
    Dec 21 14:34:57 eb-web systemd[1]: Starting nginx - high performance web server...
    Dec 21 14:34:57 eb-web nginx[2398700]: nginx: [emerg] open() "/etc/letsencrypt/options-ssl-nginx.conf" failed (2: No such file or directory) in /etc/nginx/sites-enabled/www.test.name.com.conf:37
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Failed with result 'exit-code'.
    Dec 21 14:34:57 eb-web systemd[1]: Failed to start nginx - high performance web server.
    
    Error: /Stage[main]/Nginx::Service/Service[nginx]/ensure: change from 'stopped' to 'running' failed: Systemd start for nginx failed!
    journalctl log for nginx:
    Dec 21 14:34:57 eb-web systemd[1]: Starting nginx - high performance web server...
    Dec 21 14:34:57 eb-web nginx[2398700]: nginx: [emerg] open() "/etc/letsencrypt/options-ssl-nginx.conf" failed (2: No such file or directory) in /etc/nginx/sites-enabled/www.test.name.com.conf:37
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
    Dec 21 14:34:57 eb-web systemd[1]: nginx.service: Failed with result 'exit-code'.
    Dec 21 14:34:57 eb-web systemd[1]: Failed to start nginx - high performance web server.
    Thank you.
  • h

    hbui

    12/21/2022, 4:19 PM
    nginx is trying to start, but the file /etc/letsencrypt/options-ssl-nginx.conf doesn't exist or the permissions are blocking access to the user nginx runs as
  • c

    chadh

    12/21/2022, 4:42 PM
    (assuming that will lay down the
    /etc/letsencrypt/options-ssl-nginx.conf
    file)
  • s

    Slackbot

    12/21/2022, 5:03 PM
    This message was deleted.
    ๐Ÿ‘๐Ÿป 1
    smiling face but you can see pain in their eyes 1
    panda hugs 1
    ๐Ÿ‘ 8
    b
    • 2
    • 1
  • s

    Slackbot

    12/21/2022, 8:57 PM
    This message was deleted.
    r
    j
    +2
    • 5
    • 13
  • g

    Greg Bristol

    12/21/2022, 10:52 PM
    has anybody had an issue with
    /opt/puppetlabs/puppet/cache/clientbucket/
    getting very large?
  • g

    Greg Bristol

    12/21/2022, 10:52 PM
    3.9G    /opt/puppetlabs/puppet/cache/clientbucket/
    is the current size of a lot of our systems' clientbucket
  • g

    Greg Bristol

    12/21/2022, 10:53 PM
    and all the content seems to be sshkeys
  • r

    ramindk

    12/21/2022, 11:05 PM
    I recommend turning clientbucket off and then deleting it particularly in large environments. No value in a mature system that isn't moving to config mgmt for the first time.
  • s

    Slackbot

    12/21/2022, 11:24 PM
    This message was deleted.
    r
    g
    d
    • 4
    • 4
  • c

    csharpsteen

    12/22/2022, 12:14 AM
    Starting with Puppet 7, the clientbucket is disabled in the default settings.
  • c

    csharpsteen

    12/22/2022, 12:14 AM
    For exactly this reason ๐Ÿ˜‰
  • g

    Greg Bristol

    12/22/2022, 1:18 AM
    nice
  • g

    Greg Bristol

    12/22/2022, 1:18 AM
    yeah we're on 6 currently but we'll be upgrading soon
  • g

    Greg Bristol

    12/22/2022, 1:18 AM
    thanks for the input guys
1...256257258...428Latest