https://www.puppet.com/community logo
Join Slack
Powered by
# puppet
  • m

    Massimiliano (Max)

    11/07/2022, 11:02 AM
    anyone keen to review this PR ? https://github.com/voxpupuli/puppet-fail2ban/pull/189
  • m

    Massimiliano (Max)

    11/07/2022, 11:02 AM
    anyone keen to review this PR ? https://github.com/voxpupuli/puppet-fail2ban/pull/189
  • p

    Puli Hari Krishna

    11/07/2022, 2:24 PM
    #C0W298S9G #C19V5U41Z Hi, I have configured reverse proxy in front of puppetserver and able to test access using curl. However when I try to trigger puppet agent it does not connect. Any suggestion is much appreciated. Below is config on the agent puppet.conf # Puppet config file, managed by puppet [main] vardir = /var/run/puppetlabs logdir = /var/log/puppetlabs/puppet rundir = /var/run/puppetlabs [agent] server = puppet.example.com http_proxy_host = proxy.example.com http_proxy_port = 443 environment = development Error: Puppet (err): Connection to https://proxy.example.com/puppet/v3 failed after 0.036 seconds: 400 "Bad Request curl works: curl -v --cert certs/client1.example.com.pem --key private_keys/client1.example.com.pem https://proxy.example.com/puppet/v3/environments
  • k

    krishna kant mishra

    11/07/2022, 2:39 PM
    Hi All, I need some guidance on Integration of Snow with Puppet API. Actually the goal is to run a puppet task which assign some value to a registry key.
  • c

    CVQuesty

    11/07/2022, 3:52 PM
    Good morning, everyone! Has anybody used Ventura yet? Are there any Mac/VSCode/PDK incompatibilities to be aware of?
  • r

    ripienaar

    11/07/2022, 4:33 PM
    virtualbox+vagrant nightmares
  • r

    ripienaar

    11/07/2022, 4:33 PM
    not sure if you use that, but its a mess atm
  • w

    William Myers

    11/07/2022, 4:35 PM
    Aside from moving the data into Hiera, what are some ideas on things i could do better with this module? https://puppetcommunity.slack.com/archives/C0W298S9G/p1667625549358439
  • j

    jhoblitt

    11/07/2022, 7:28 PM
    @binford2k I have just discovered that https://yum.puppet.com/puppet7/puppet7-release-el-9.noarch.rpm doesn't exist. It appears that the
    -release
    packages for EL9 are only under /puppet/el/9/x86_64. This isn't the end of the world but it is a slight irritation as the default foreman/satellite provisioning templates assume they can construct a path to an rpm using
    rpm -Uvh<%= http_proxy %><%= http_port %> https://<%= repo_host %>/<%= repo_name %>-<%= repo_os %>-<%= os_major %>.noarch.rpm
    . Is this the "new way forward" and I need to PR a foreman fix or just an oversight?
  • j

    jhoblitt

    11/07/2022, 7:29 PM
    EL9.1 is about to come out of beta and the interest in EL9 will surely go up dramatically when it does.
  • j

    jhoblitt

    11/07/2022, 7:36 PM
    wait, huh, https://yum.puppet.com/puppet-release-el-9.noarch.rpm exists
  • j

    jhoblitt

    11/07/2022, 7:38 PM
    Is that now the preferred naming pattern, without the
    puppet<release>
    sub dir?
  • v

    vchepkov

    11/07/2022, 7:58 PM
    I have been using
    <http://yum.puppet.com/puppet7-release-el-9.noarch.rpm>
  • v

    vchepkov

    11/07/2022, 8:00 PM
    server platform is still not available for el9 though
  • c

    conzar

    11/07/2022, 10:20 PM
    Is there an issue with the Puppet Forge - being able to publish modules?
  • s

    Slackbot

    11/07/2022, 10:20 PM
    This message was deleted.
    b
    c
    o
    • 4
    • 34
  • c

    conzar

    11/07/2022, 10:21 PM
    I also noticed that my Gravatar isn't showing when I login, probably due to this error:
    Copy code
    GET <https://gravatar.com/avatar/null.png?r=pg&s=20&d=404> 404
  • s

    Slackbot

    11/08/2022, 7:00 AM
    This message was deleted.
    o
    • 2
    • 1
  • b

    Bernd Schatz

    11/08/2022, 7:01 AM
    e.g. --> https://forge.puppet.com/v3/files/puppetlabs-docker-5.1.0.tar.gz or https://forge.puppet.com/v3/files/puppetlabs-apache-8.3.0.tar.gz or any other links work not anymore.
  • b

    binford2k

    11/08/2022, 7:09 AM
    @Bernd Schatz it does appear to be so. I'll ping the team and they'll get on it first thing in the morning. In the meantime, manually correct the URL like so (forge -> forgeapi): • https://forgeapi.puppet.com/v3/files/puppetlabs-docker-5.1.0.tar.gz • https://forgeapi.puppet.com/v3/files/puppetlabs-apache-8.3.0.tar.gz
    👍 1
  • s

    Slackbot

    11/08/2022, 9:03 AM
    This message was deleted.
    d
    k
    • 3
    • 11
  • k

    krishna kant mishra

    11/08/2022, 9:10 AM
    Can anybody pls help me out
  • s

    Slackbot

    11/08/2022, 10:33 AM
    This message was deleted.
    t
    n
    • 3
    • 2
  • n

    Neeloj

    11/08/2022, 10:35 AM
    hi all, in my manifest:
    Copy code
    file { 'test_folder':
              ensure             => 'directory',
              source             => 'puppet:///modules/test',
              recurse            => true,
              purge              => true,
              force              => true,
              path               => 'C:/test',
              source_permissions => ignore,
              notify             => Exec['prepare.ps1'],
      }
    
      exec { 'prepare.ps1':
              path        => $::path,
              command     => "& c:\\test\\prepare.ps1",
              provider    => powershell,
              subscribe   => File['test_folder'],
              logoutput   => true,
              refreshonly => true
      }
    On client puppet agent -t
    Error: '& c:\test\prepare.ps1; Exit 0' returned 1 instead of one of [0]
    Error: /Stage[main]/Test::Copy/Exec[prepare.ps1]/returns: change from 'notrun' to ['0'] failed: '& c:\test\prepare.ps1; Exit 0' returned 1 instead of one of [0] (corrective)
    Does anyone know why ? Tahnk you all
  • g

    Guillem Liarte

    11/08/2022, 10:57 AM
    Hello
  • s

    Simon Karberg

    11/08/2022, 11:51 AM
    hey, with postgresql module from puppetlabs, how can define to install extra packages? e.g. i want to install
    decoderbufs
    with my pgsql. i could "hardcode" it in my
    class { 'postgresql::server' }
    but that is hardcoded 🤔
  • a

    Artem Shaposhnikov

    11/08/2022, 1:01 PM
    Hello everybody, does anybody know how to fix it. I'm trying to check certificate requests and get this: Fatal error when running action 'list' Error: Failed connecting to https://xxxxxxx:8140/puppet-ca/v1/certificate_statuses/any_key?state=requested Root cause: SSL_connect returned=1 errno=0 state=error: certificate verify failed (self signed certificate in certificate chain) Any ideas? Thanks in advance
  • b

    Brian Schonecker

    11/08/2022, 1:10 PM
    I'm looking for advice on how to manage CIS rules for EFI booting RHEL-based systems. I'm using jcpuni/efi module to determine if the server was booted in EFI mode. The CIS rule requires that I modify /etc/fstab and ensure that
    fmask=0077
    is added to the entry for the EFI partition (in my case /boot/efi). On all the servers, the UUID for the /boot/efi is different (as it should be). For example:
    UUID=EC55-4757  /boot/efi       vfat    defaults,uid=0,gid=0,umask=077,shortname=winnt  0       2
    is an entry on one of my servers. I know I can use the mount resource to manage the mount, but I'm having trouble determining how to acquire the UUID=EC55-4757 and all of the existing mount options (in my example) in order to manage the mount. I could (probably) write a very bad custom fact in order to get that information but I'm terrible at Ruby and I'm sure someone else must have this or a similar problem. I really don't want to use augeas if possible as that seems a bit dirty/hacky. Additional (possibly) helpful information:
    /dev/sda1 => {
    filesystem => "vfat",
    label => "EFIFS",
    mount => "/boot/efi",
    partlabel => "EFI System Partition",
    partuuid => "45f4fd67-8dab-4f7b-9d7c-f46959d28c60",
    size => "1.00 GiB",
    size_bytes => 1073741824,
    uuid => "E0F3-019B"
    },
    /boot/efi => {
    available => "1012.13 MiB",
    available_bytes => 1061289984,
    capacity => "0.97%",
    device => "/dev/sda1",
    filesystem => "vfat",
    options => [
    "rw",
    "relatime",
    "fmask=0077",
    "dmask=0077",
    "codepage=437",
    "iocharset=ascii",
    "shortname=winnt",
    "errors=remount-ro"
    ],
    size => "1021.99 MiB",
    size_bytes => 1071632384,
    used => "9.86 MiB",
    used_bytes => 10342400
    },
    efi => true
    Can anyone lend any suggestions?
  • b

    Brian Schonecker

    11/08/2022, 1:11 PM
    I'm looking for advice on how to manage CIS rules for EFI booting RHEL-based systems. I'm using jcpuni/efi module to determine if the server was booted in EFI mode. The CIS rule requires that I modify /etc/fstab and ensure that
    fmask=0077
    is added to the entry for the EFI partition (in my case /boot/efi). On all the servers, the UUID for the /boot/efi is different (as it should be). For example:
    UUID=EC55-4757  /boot/efi       vfat    defaults,uid=0,gid=0,umask=077,shortname=winnt  0       2
    is an entry on one of my servers. I know I can use the mount resource to manage the mount, but I'm having trouble determining how to acquire the UUID=EC55-4757 and all of the existing mount options (in my example) in order to manage the mount. I could (probably) write a very bad custom fact in order to get that information but I'm terrible at Ruby and I'm sure someone else must have this or a similar problem. Can anyone lend any suggestions?
  • b

    Brian Schonecker

    11/08/2022, 1:11 PM
    I'm looking for advice on how to manage CIS rules for EFI booting RHEL-based systems. I'm using jcpuni/efi module to determine if the server was booted in EFI mode. The CIS rule requires that I modify /etc/fstab and ensure that
    fmask=0077
    is added to the entry for the EFI partition (in my case /boot/efi). On all the servers, the UUID for the /boot/efi is different (as it should be). For example:
    UUID=EC55-4757  /boot/efi       vfat    defaults,uid=0,gid=0,umask=077,shortname=winnt  0       2
    is an entry on one of my servers. I know I can use the mount resource to manage the mount, but I'm having trouble determining how to acquire the UUID=EC55-4757 and all of the existing mount options (in my example) in order to manage the mount. I could (probably) write a very bad custom fact in order to get that information but I'm terrible at Ruby and I'm sure someone else must have this or a similar problem. I really don't want to use augeas if possible as that seems a bit dirty/hacky. Can anyone lend any suggestions?
1...228229230...428Latest