This message was deleted.
# citrix-vad
s
This message was deleted.
s
There is a version of the article on Wayback, but it doesn't say much... https://web.archive.org/web/20210721002424/https://support.citrix.com/article/CTX241337
Searching that CTX number takes you here:
I don't want to sound like every "solution" on MS forums, but have you tried running 'sfc /scannow'?
g
Thanks for the input, Scott! Really appreciate it.
In case anyone else has this issue, here's what I did to get it working again:
1. Disabled the "Print Spooler" service 2. Rebooted the computer 3. Ran CMD as Administrator 4. Typed this at the command prompt: SC CONFIG SPOOLER DEPEND=RPCSS and hit Enter 5. Re-enabled the "Print Spooler" service and set it to Automatic (then Apply and then OK) 6. Right-clicked the "Print Spooler" service and clicked START
As to why the Print Spooler service failed at all, I'd have to dig into it more. But those actions seem to have restored it.
UPDATE: You need to "Fix" the http service as well, or else the VDA install / re-install will fail:
To FIX the HTTP Service: 1. Ran CMD as Administrator 2. Typed this at the command prompt: sc config http start=disabled and hit Enter 3. Rebooted the Machine 4. Ran CMD as Administrator 5. Typed this at the command prompt: sc config http start=demand and hit Enter 6. Re-ran the VDA install and it worked this time After fixing these Services, the PRINT SPOOLER Service starts again. THEREFORE, the VDA can then be installed / re-installed, and the VM should power ON and be able to REGISTER in Studio.