A bit of a weird one today. All Agents across mu...
# citrix-wem
m
A bit of a weird one today. All Agents across multiple images not checking in with the database. No registrations seen. Services running on Infrastructure server fine. If you use the AgentUtility it fails to initialize sayng: Cache sync failed with error: SyncFailed. Interesting though, on the Infrastructure server i see an event - LSA 6037 (usually rubbish of no consequence) but I see in there Broker error message. Thinking this may be related. Anyone else see anything similar? I’m wondering at this point if some AV or Security agent is blocking something.
h
That target name is the name of the SPN not the server. Did the SPN get lost? Also.... Did VDA/WEM agent get upgraded recently?
m
Thanks guys. @Hal Lange No, no updates on the VDA or WEM agent - and it affects two different images, which have not been updated. So it’s something on either the WEM Infrastructure server or SQL server. Services are running on the server and you can run the console just fine. But not a single agent is checking in - the list of agents is blank. This server is taken care of by another engineer so I don’t have deep details on what was done recently on the server itself. How would an SPN “get lost”? I’d like more info on that.
Here’s an additional update. While having a meeting with the team today, I was reviewing the issue, covering what I’d tried to date, and asked if anyone had changed anything. Immediately after this call wrapped, I looked down at the console and it all agents were checking in again, from both images. If it was anything I’d done previously, it was greatly delayed (and after I make any changes, I actively was restarting services, forcing sync, yada yada) and nothing had worked. So it was like phoning your telco “No, we didn’t change anything”, you hang up and your system is working again. I don’t like not knowing, so this bothers me.
s
That's weird. Have you found any useful information from the agent debug log or broker log?
m
I looked in various logs and basically they were variations of “unable to connect”.
s
could you share some section? thanks!
m
What section do you want to see, @Sharp Guo? Happy to provide info if it helps get to the root cause. It’s working now, but I’m not 100% sure why
s
just want to know about the "unable to connect" log information in the log files.
m
Sorry for the delayed response here - I’ll see if I can still find the log and will paste here if I do