- Upgraded WEM Server and DB to 2311.1.0.1 from 22...
# citrix-wem
c
• Upgraded WEM Server and DB to 2311.1.0.1 from 2212.1.0.1 • Prod VDA with WEM 2212.1.0.1 connect fine • Test VDA with WEM 2311.1.0.1 seems to connect fine but the WEM Agent errors When logging in or refreshing the WEM Agent 2311.1.0.1 we get: • 23446 PM Event -> MainController.ReadAgentConfiguration() : Reading JSON File Configuration Global Settings... • 23446 PM Exception -> VuemAgentConfigurationHelper.ReadJsonFileConfigGlobalSettings() : System.ServiceModel.FaultException`1[Norskale.Common.Data.Faults.DataReaderFault]: The creator of this fault did not specify a Reason. (Fault Detail is equal to Norskale.Common.Data.Faults.DataReaderFault). • 23446 PM Exception -> MainController.ReadAgentConfiguration() : Agent JSON File Configuration Global Settings Retrieval Failed. Exiting...
l
Hello, Did you try to reset Wem Cache on your VDA ? You can use a Script : net stop "Citrix WEM Agent Host Service" /y del /f "C:\Program Files (x86)\Citrix\Workspace Environment Management Agent\Local Databases\*.db" net start "Citrix WEM Agent Host Service "c:\Program Files (x86)\Citrix\Workspace Environment Management Agent\AgentCacheUtility.exe" -refreshcache pause
c
The VDA was a complete new build that installed WEM 2311, wasn’t an upgrade to 2311. Did test a cache refresh anyway but same issue
l
Maybe a bug in these version ? I think it's necessary to open a citrix case. For years I had some similar problems with WEM 2203 and these version had a bug which was fixed in 2206.
c
Found that running AgentCacheUtility.exe -refreshcache -reinitialize resolved the issue but this was a fresh VDA build and checks into WEM successfully. Case logged anyway