This message was deleted.
# citrix-vad
s
This message was deleted.
r
So your doing in place upgrades on DDC and PVS but building new for storefront?
k
Yeah. Storefront is explicitly not supported and we have the boxes built. Just trying to get the rest finished off as soon as possible as part of a toxic project. It's a short term solution.
r
Hmm, please make sure you have a fallback option. I always build new and add to the Site with new DDC and PVS. Then I remove the old ones. I never do in-place OS upgrades. I can't tell you what will happen. It's not common practice. The only time I did an OS upgrade was on a Lic Server, but that was a lab. They even go into it some here on the DDC. PVS https://support.citrix.com/article/CTX277841/how-to-perform-os-upgrade-on-a-citrix-provisioning-server https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/upgrade-migrate/upgrade.html#add-new-machines-and-then-remove-old-machines
k
Thanks for that...yes I'm having new machines built as a plan B (well plan C but long story). Will take snapshots and backup the DBs and only do one server at a time and back out if it doesn't work. I'm less worried about the PVS than I am the DDCs.
r
how did it go?
k
It hasn't yet...start on Saturday
r
Okay. Just wanted to check on you.
k
Much appreciated! I'll keep you posted :)
👍 1
r
Thanks man.
u
d
Do yourself a favour and install new VM‘s. There are several ways of migrating your settings. The PVS vDisks are easy to migrate anyway.
k
Sorry meant to reply. DDCs required reinstall of PowerShell snapins post upgrade for Studio. PVS were straight forward....nothing required just stop the stream service and upgrade one at a time.
r
Other than that all went well?
k
Yeah all sweet...no issues. It was pretty much as expected and I arranged an outage while I did the DDCs. Managed to do the PVS with no down time
r
Congrats man. I happy it went well for you.
k
Cheers... appreciate it
r
Np. Anytime you need help. We all are here to guide and help.
❤️ 1
b
File from Jon Bucud (MyCUGC) with comment: Congrats it went off w/o much pain! I've done a few low impact 2012R2 -> 2016/2019's IPUs and most go smoothly/are non events. Had one weird one where .net needed to be reinstalled, but eventlogs had a real good "in english; .net failed to load, do you want to install it?" error.
j
Just got this note from one of my teammembers as well, who IPU'd a print server.
Copy code
FYI — with an OS upgrade, if you run into a component failure (e.g., "0xc1900101 - 0x3001 - The installation failed in the FIRST_BOOT phase with an error during SYSPREP") the offending role/feature might be found in an error entry near the end of setupact.log in $Windows.~BT\Sources\Panther\. In the case of XXXXX, it was the Internet Printing role.
m
Inofficial and not supported answer: As a CSP we support several very small CVAD environments, with <100 user and only one central DDC which holds all roles like DC, SF, Director etc. During a planned downtime and with a working backup in place, we have done a few IPU to Windows Server 2019/2022 without any further issues. I know it's unsupported, but it's way faster, when it works out. Just be prepared for failure (which we hadn't, yet) We've done the same for RDSH/VDA hosts, but in that case we've cloned and sysprepped the VDA first, and let it run in parallel, so the customer had time to test the new VDA, before switching it into the production environment.