This message was deleted.
# citrix-vad
s
This message was deleted.
j
Clearly NetLogon is failing for some reason - what do the event logs say?
w
I can't log in or connect to the server's event logs remotely. Glad I have snapshots.
I also built a Win10 MC/DG and have no issues with those two VMs.
I'll revert to the snapshot before installing VDA 2303 and make sure the master image is happy and try again.
j
Do you get the same behaviour with an older VDA?
w
Specifically need to test 2303, but I'll try prior versions if the next test fails.
k
Can you logon with the local admin account and review Eventlogs?
w
Nope, gives me an error stating no cached credentials exist and try logging in with an account with cached credentials
I don't think it matters, but neither master image is domain-joined
k
Can you connect with remote MMC to the eventvwr or services.msc?
w
Nope
error says unable to connect
This is just a basic server build. nothing special, no tweaks, no optimizations, no customizations. I installed Server 2022, then all Windows Updates, restarted, checked for more updates, shut down the VM, took a snapshot, powered on the VM, installed VDA 2303, restarted, shut down, took another snapshot, and used MCS to build the MC. Then I built the DG with the two machines created, the VMs powered on, and then nothing worked. No registration, unable to log in using local or domain creds and no remote connection to services or event logs. Just the message about the netlogon srvice not running.
After installing the VDA on the master image, I can log in, and there are no unusual errors or warnings in the event logs.
Same issues. I am going to try the fix from @Guy Leech https://github.com/guyrleech/Microsoft/blob/master/Change%20service%20dependencies.ps1 & '.\Change service dependencies.ps1' -property displayname -services "Citrix Desktop Service","Citrix Stack Control Service" -add "Remote Desktop Services"
Same error
g
Shutdown, attach disk to another vm and load the application and system event log files from %SystemRoot%\System32\Winevt\Logs
Maybe also set procmon to boot manually in the registry (don't forget to set the accepteula reg value) to a local pml file that you can get from attaching to another VM. Set procmon boot logging on another VM and copy HKLM\system\currentcontrolset\services\procmon* key and values over
w
I see nothing unexpected in the remote servers (built with MCS) event logs. I will revert and test with 2212.
j
I've seen this with PVS when I selected the wrong machine type during VDA installation (manual install), choosing first the wrong machine type. I think in my case it was a failed dependency service for Netlogon that pointed me in the right direction. Same symptoms when putting the pvs disk into production and streaming it.
w
i selected multi-session since this is a server os
I had no issue with Server 2019. I have yet to find a way to get VDA 2303 or 2212 to work with Server 2022.
Citrix wants me to open a support case for both of my VDA issues so they can assign engineering resources.
👍 1