On Windows + Docker Desktop I got PHPCS to work from PHPStorm, but had to install php on the WSL2 Ubuntu instance.
PHPStan does not work from PHPStorm, always tells me no rules found, although it reads the included neon file, because if I change something in that to not be configured correctly it throws an error.
As PHPStan seems to have been added to PHPStorm only recently, I guess there may be still problems with remote cli interpreters?