acoustic-holiday-14924
02/12/2021, 5:11 PMcommand docker start xxxxxx_dev_data_sync && docker exec xxxxxx_dev_data_sync supervisorctl restart unison
ok starting initial sync of xxxxxx_dev_data_sync
command docker inspect --format='{{(index (index .NetworkSettings.Ports "5000/tcp") 0).HostPort}}' xxxxxx_dev_data_sync
command unison -testserver /app_sync "<socket://127.0.0.1:49158>"
Traceback (most recent call last):
15: from /usr/local/bin/docker-sync:23:in `<main>'
14: from /usr/local/bin/docker-sync:23:in `load'
13: from /var/lib/gems/2.7.0/gems/docker-sync-0.5.14/bin/docker-sync:14:in `<top (required)>'
12: from /var/lib/gems/2.7.0/gems/thor-0.20.3/lib/thor/base.rb:466:in `start'
11: from /var/lib/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:387:in `dispatch'
10: from /var/lib/gems/2.7.0/gems/thor-0.20.3/lib/thor/invocation.rb:126:in `invoke_command'
9: from /var/lib/gems/2.7.0/gems/thor-0.20.3/lib/thor/command.rb:27:in `run'
8: from /var/lib/gems/2.7.0/gems/docker-sync-0.5.14/tasks/sync/sync.thor:47:in `start'
7: from /var/lib/gems/2.7.0/gems/docker-sync-0.5.14/tasks/sync/sync.thor:170:in `daemonize'
6: from /var/lib/gems/2.7.0/gems/docker-sync-0.5.14/lib/docker-sync/sync_manager.rb:102:in `start_container'
5: from /var/lib/gems/2.7.0/gems/docker-sync-0.5.14/lib/docker-sync/sync_manager.rb:102:in `each'
4: from /var/lib/gems/2.7.0/gems/docker-sync-0.5.14/lib/docker-sync/sync_manager.rb:103:in `block in start_container'
3: from /var/lib/gems/2.7.0/gems/docker-sync-0.5.14/lib/docker-sync/sync_process.rb:105:in `start_container'
2: from /var/lib/gems/2.7.0/gems/docker-sync-0.5.14/lib/docker-sync/sync_strategy/unison.rb:211:in `start_container'
1: from /var/lib/gems/2.7.0/gems/docker-sync-0.5.14/lib/docker-sync/sync_strategy/unison.rb:211:in `loop'
/var/lib/gems/2.7.0/gems/docker-sync-0.5.14/lib/docker-sync/sync_strategy/unison.rb:216:in `block in start_container': Failed to start unison container in time, try to increase max_attempt (currently 5) in your configuration. See <https://github.com/EugenMayer/docker-sync/wiki/2.-Configuration> for more informations (RuntimeError)
Increasing the timeout (even to 10 minutes) did not help.
The unison.log wihtin the WSL just prints the following during each attempt:
Fatal error: Failure reading from the standard input (End of file)
Looking at the output within the docker-sync container does not show an issues:
2021-02-12 17:43:46,504 INFO spawned: 'unison' with pid 34
2021-02-12 17:43:47,512 INFO success: unison entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
Has anyone seen this issue, and know what to do about it? Restart of the WSL1 instance, the computer itself, docker did not help. Also removing the docker-sync container including all volumes does not help.
Any hint what could be the issue, would be very much appreciated. Also if you know any files or directories within WSL that belog to docker-sync / unison that are safe to remove, let me know.