Ive also recently tried it without any custom doma...
# seed
Ive also recently tried it without any custom domain settings in the stack and still get the error 🤔
@Tharshan do you get the same error when deploying locally?
@Frank yes - I am able to reproduce it locally
Copy code
staging-slack-feedback-widget-my-stack | CREATE_FAILED | AWS::CloudFront::OriginRequestPolicy | SiteImageOriginRequestFA9A64F5 Internal error reported from downstream service during operation 'AWS::CloudFront::OriginRequestPolicy'.
staging-slack-feedback-widget-my-stack | CREATE_FAILED | AWS::CloudFormation::CustomResource | SiteCertificateCertificateRequestorResource86F17F2A 
staging-slack-feedback-widget-my-stack | CREATE_FAILED | AWS::IAM::Policy | SiteRegenerationFunctionServiceRoleDefaultPolicy7892BFA2 
staging-slack-feedback-widget-my-stack | CREATE_FAILED | AWS::CertificateManager::Certificate | ApiCertificate285C31EB
Here is the error logs I see
I upgraded from 0.50.2 to 0.52.0 and I was able to reproduce the same issue.
Will DM you the stack file. As that might provide more context.
@Tharshan do you get this error consistently?
Can you go into your AWS CloudFront console > Policies > Origin requests, and see how many Custom policies do you have?
Let me check! @Frank
Yes - I do get it consistently
Tried on staging stage
and prod stage too
@Frank I have 12 policies
Hey @Frank - were you able to see anything on those policies? anything else we can try to debug? It’s preventing us deploying to the domain
Hey @Tharshan can you try creating a new origin request policy through the console?
Like this
And see if you are able to create one.
@Frank yes - I am able to create one just fine