https://www.puppet.com/community logo
Join Slack
Powered by
# puppet-enterprise
  • v

    vchepkov

    07/24/2026, 4:53 PM
    also, seems some dependencies are missing
    Copy code
    2026-07-24T16:50:14.555+00:00 - [Error]: Could not find a suitable provider for cron
  • v

    vchepkov

    07/24/2026, 4:54 PM
    I guess original question stand - is it really supported?
  • b

    bastelfreak

    07/24/2026, 5:17 PM
    I am still dreaming about a future with systemd timers and no crons
    โ˜๐Ÿผ 1
    ๐Ÿ’ฏ 1
    โž• 1
  • s

    Sharpie

    07/24/2026, 6:46 PM
    I recall something else about Amazon 2023. No
    syslog
    by default, maybe?
  • v

    vchepkov

    07/24/2026, 7:48 PM
    nope, only journald
  • b

    bastelfreak

    07/24/2026, 8:05 PM
    This is the way
  • j

    Jason St-Cyr

    07/25/2026, 2:53 AM
    @vchepkov: Amazon 2023 is supposed to be supported as a platform, this sounds like a bug with PEADM.
  • t

    tuxmea

    07/28/2026, 1:24 PM
    On PE 2025.11.0 when managing EC encryption using a Puppet custom function the pe-puppetserver throws an exception. Same error message as in older OpenVox server packages: github.com/OpenVoxProject/openvox-server/issues/322. Solution is to upgrade jruby-openssl
    s
    m
    • 3
    • 4
  • t

    tuxmea

    07/30/2026, 11:45 AM
    Why are there environements with empty name in puppetdb? Customer queries puppetdb for env using: curl localhost/pdb/query/v4/environments | python3 -m json.tool
  • t

    tuxmea

    07/30/2026, 11:45 AM
    Result:
  • t

    tuxmea

    07/30/2026, 11:45 AM
    Copy code
    [
        {
            "name": "production"
        },
        {
            "name": ""
        },
        {
  • t

    tuxmea

    07/30/2026, 11:45 AM
    And: how to get rid of the env with empty name? We also see entries in postgresql referencing the empty env id
  • t

    tuxmea

    07/30/2026, 11:46 AM
    /opt/puppetlabs/server/bin/psql -d pe-puppetdb -c โ€˜select * from environments;โ€™ id | environment -----+------------------------------------------------------------------- 1 | production 258 | 259 |
  • t

    tuxmea

    07/30/2026, 11:51 AM
    /opt/puppetlabs/server/bin/psql -d pe-puppetdb -c โ€˜select count(*) from reports where environment_id = 258;โ€™ count ------- 5 (1 row)
  • t

    tuxmea

    07/30/2026, 11:55 AM
    select id, certname, puppet_version, producer_timestamp from reports where environment_id = 258;
  • t

    tuxmea

    07/30/2026, 11:55 AM
    shows us that this occurred during PE 2025.11 update on the replica.
  • t

    tuxmea

    07/30/2026, 11:56 AM
    Correction: the reports have been stored during the upgrade of the primary, but with the old puppet agent version on the replica.
  • j

    Jay Iorio

    08/19/2026, 8:28 PM
    Need some help.. Have Vulns for Postgres 4.22 with remediation to 4.23, But PE 2025.10 is at 4.22 with 2025.11 jumping to Postgres 17. Same Vuln sez it needs to be at least 17.10. Can I get some help / validation that Postgres goes to 17.10 in 2025.11 before I make this jump?
    t
    j
    • 3
    • 7
  • c

    Chad

    08/20/2026, 3:25 PM
    Along with the theme of vulnerabilities scans I see our scanner is flagging nginx/1.28.2 as EOL. Newer version coming soon in PE?
    t
    • 2
    • 1
  • v

    vchepkov

    08/27/2026, 5:00 PM
    A heads up - PE2025.11.2 release breaks eyaml. From what I can tell BouncyCastle 1.85 is to blame
    s
    • 2
    • 3
  • v

    vchepkov

    08/27/2026, 5:24 PM
    yep. here is the story PE 2025.11.2 ships /opt/puppetlabs/share/java/bcprov-jdk18on-1.85.jar; 2025.11.0 shipped 1.84. BouncyCastle 1.85 rejects X.509 certificates whose issuer DN is empty. Certificates produced by "eyaml createkeys" have an empty subject AND an empty issuer DN, so they can no longer be parsed inside puppetserver.
  • s

    steveax

    08/27/2026, 5:26 PM
    yep, repro'd here
  • j

    Jay Iorio

    08/27/2026, 7:35 PM
    Ugh So don't go there or is there an easy workaround?
    s
    • 2
    • 3
  • v

    vchepkov

    08/27/2026, 7:38 PM
    I hacked pkcs7.rb
  • v

    vchepkov

    08/27/2026, 7:39 PM
    But I won't go prod with that ๐Ÿ™‚
  • b

    bastelfreak

    08/27/2026, 7:40 PM
    patches welcome ๐Ÿ™‚
    s
    s
    v
    • 4
    • 35
  • j

    Jay Iorio

    08/27/2026, 7:47 PM
    Thanks Everyone for sharing...
  • e

    erik

    08/27/2026, 9:04 PM
    it also fails for us here:
    Copy code
    2026-08-27T21:01:52.439+00:00 [ERROR]: Your pe.conf file at /opt/puppetlabs/server/data/staging/pe_repo-puppet-agent-8.20.0/puppet-enterprise-2025.11.2-el-9-x86_64/conf.d/custom-pe.conf contains errors.
    2026-08-27T21:01:52.446+00:00 [ERROR]: Check your pe.conf file for errors and try re-running the installer.
  • e

    erik

    08/27/2026, 9:10 PM
    unfortunately this was also supposed to fix the compilers-fail-to-check-in-after-MoM-restarts thing so looks like we're stuck ๐Ÿ˜ข
  • e

    erik

    08/27/2026, 9:11 PM
    ah. so earlier in the log, I see this:
    Copy code
    ## We're checking if /opt/puppetlabs/server/data/staging/pe_repo-puppet-agent-8.20.0/puppet-enterprise-2025.11.2-el-9-x86_64/conf.d/custom-pe.conf contains valid HOCON syntax...
    
    2026-08-27T21:09:31.367+00:00 Running command: /opt/puppetlabs/installer/bin/validate_pe_conf.rb /opt/puppetlabs/server/data/staging/pe_repo-puppet-agent-8.20.0/puppet-enterprise-2025.11.2-el-9-x86_64/conf.d/custom-pe.conf
    ./puppet-enterprise-installer: line 665: /opt/puppetlabs/installer/bin/validate_pe_conf.rb: No such file or directory
    2026-08-27T21:09:31.382+00:00 [ERROR]: !! Validation failure. !!
    Rolling puppet-agent back to 8.20.0.
    Rolling pe-installer back to PE 2025.11.0.
    Rolling pe-modules back to PE 2025.11.0.
    something missing from the installer build?
    s
    c
    • 3
    • 5
1...6970717273Latest