I deleted my old project, which was on a custom do...
# general
k
I deleted my old project, which was on a custom domain, and created a new one. I am not able to add my old custom domain (now unused) to this one: Conflict - hosted zone already exists (Request ID: r-db29fbc0) also I can't be sure but I think when I redeployed with new source code, the old source code from a previous upload was being deployed
e
@Gui can you check this?
g
@Omer Bar-Ness did you take a look in the end ? otherwise I'll do it
@Kapil Sinha You should now be able to add your app.gotelemag.com domain to your application. As for:
redeployed with new source code, the old source code from a previous upload was being deployed
We will try to reproduce this issue. Let us know if you spot it again Please let us know if you are facing any other problem
k
I still see the same error
i
@Kapil Sinha are you trying to add a custom project name or a full domain? Also what are you seeing?
k
I've tried adding both app.gotelemag.com and gotelemag.com
(which makes sense, the domain is already registered. But I don't see it in any dropdown menu)
g
@Kapil Sinha do you see your domain
<http://app.gotelemag.com|app.gotelemag.com>
in the app settings for
restless-river-5026
?
k
It popped up now to my one app (which must be restless-river? I don't see that name). Should this just work? The custom domain is "not found"
g
You will have to update your DNS so it match the config for that custom domain
k
Again? I already used this custom domain on the previous app. it shows that it is validated
g
Your DNS for app.telemag.com points to:
Copy code
;; ANSWER SECTION:
<http://app.gotelemag.com|app.gotelemag.com>.      3590    IN      CNAME   telemag.ploomberapp.io.
Which return a 404. If you look at the config, I think you would see another CNAME value which need to be entered in your DNS
k
Good call. I've deployed a new app at telemag.ploomberapp.io, which should mean the DNS settings don't change. Now I run into more issues: "Failed to fetch custom domains for project : 'throbbing-poetry-1152')" Am I doing this incorrectly? Sorry for creating these issues, I'm sure this is frustrating for you as well. [edit] Actually this may have worked now. Waiting for DNS to resolve
g
@Kapil Sinha No worry, we are here for that 🙂 I still see the cert issue. Can you update your DNS for
telemag.ploomber.app.
instead of
<http://telemag.ploomberapp.io|telemag.ploomberapp.io>.
? (We recently did some work to have faster deployment, and updated the domain to
ploomber.app
, which might causes problem at the moment)
k
Updated this over an hour ago by the way. I still see the cert issue. I'll give it a few more hours
i
I see the URL is available, please confirm?
k
app.gotelemag.com isn't working still
o
@Kapil Sinha the domain leads to a page that shows your connection is not secure The reason is that you need to create / edit the entry with your domain provider. This domain was pointing to a different project name previously, so you probably already have the entry for that. If you open your app settings (when it's in a running state) you will see the issued certificate, and a message that reads This domain is not attached to any application. Follow the instruction below it to fix this issue.
g
@Kapil Sinha We found the root cause of the problem. App.gotelemag.com is working. If you have another domain affected. Let us know. Again, sorry for this
k
Works, thank you
Actually there's that certificate error again. The CNAME in the help page (your screeenshot above) seems to have changed
g
I've re-applied a temporary fix to solve the error. The team is working on a permanent solution, and I'll monitor your app until the root cause is resolved to make sure the error doesn't re-appear
k
I added the new CNAME to my site fyi