This message was deleted.
# papercups
s
This message was deleted.
t
papercups_postgres log says :
Copy code
19:52:38.752 [error] Postgrex.Protocol (#PID<0.3136.0>) failed to connect: ** (Postgrex.Error) FATAL 28P01 (invalid_password) password authentication failed for user "postgres"
Similar in papercups container But it was working previosuly Maybe the user accounst are stored and not wiped, but papercups cannot fetch them from postgres. If so, why might postgres connection be dropping?
k
Are you using docker self hosting or heroku self hosting?
t
Well, I have tried 2. Self-hosted docker and then papercups on caprover from "stock" one-click install. Both show same behaviour. Leave the dashboard open, and usually overnight, you're logged out in morning and can't log back in again
On caprover, I can re-register same user same password. All settings wiped and new account id assigned. Suggests all system settings wiped. I have the docker containers set with restart policy "unless stopped"
k
Hmmm can you try on heroku? You most likely need to tweak the docker compose files to persist the database or use a separate database instance. Docker compose files tend to be ephemeral.
i haven’t had the chance to tweak it yet but I think best way is to set up https://docs.docker.com/storage/volumes/ since all the disk on docker is ephemeral
t
I did an initial trial on Heroku and it was fine there. Heroku is great for trials. But for production i moved to a VPS.
Thank you - will check the and compare the volumes