I’d like to update the nf-schema plugin to v3.0, b...
# team-maintainers
m
I’d like to update the nf-schema plugin to v3.0, but that requires NF >= 26.04. Can we bump the minimal version in #CJRH30T6V? PR: github.com/nf-core/modules/pull/13069
cc @Nicolas Vannieuwkerke
s
That seems fine to me
🎉 1
m
What is our timeline for this already?
m
I don’t think there’s any blockers for modules
n
yeah all modules should be up to date now and otherwise they will be forced to update
m
@mashehu can you confirm?
m
sorry, not 100% up-to-date with what has changed in nextflow nf-schema here: will we loose backwards compatibility in modules, i.e. will I still be able to run modules with 25.10?
(we will bump the minimal nextflow version to 26.4 in the tempalte probably in november)
m
All modules should be compatible already
so they can all run on both versions
m
awesome
n
only the nf-schema subwf will not be backwards compatible
(hence the 3.0.0 release)
m
Please approve the PR if there’s no blocks
That way it isn’t only my fault if something does break
🤣 1
m
For me if we plan to bump in November in the template we should be safe to bump now in modules
party this 1
🎉 1
Also, we should really move to using the nf-core-utils plugin and stop relying on the subworkflows
party this 4
m
I think the template needs to be updated for that
m
And we probably need a release of the plugin as well
m
yeah, that might also be useful 😄
m
That sounds like a nice post hackathon project
m
PR is merged, thx all
exceptionallyfastparrot 1
elmofire 1