Attention plugin maintainers: we just released <Ne...
# nextflow-plugins
b
Attention plugin maintainers: we just released Nextflow 24.01.0-edge which upgraded from Groovy 3 to 4. Third-party plugins which are built with Groovy 3 may not be compatible with this new release. I recommend that you test the current version of your plugin with the new release to see if there are any issues. You might not need to upgrade right now, but I would do it no later than the next major Nextflow release in April. You can follow this example to see how to upgrade your plugin to Groovy 4. The new plugin version should specify >=24.01.0-edge as the required version If you want to still be able to make patch releases to previous plugin versions, you can do so by maintaining a separate branch for the previous version. For example, suppose I have a plugin at version 1.2.1. I will create a new branch at this commit called 1.2.x which will be used to create patch releases for the Groovy 3 build, and on the main branch I will upgrade to Groovy 4 and release 1.3.0. In most cases this likely isn't needed though. Feel free to message me if you need help.
🚀 1
🤩 1
s
ping @User
c
Hey @Ben Sherman, thanks for the heads up. Here's a PR for one of my plugins. If you spot anything wrong, please let me know! I'll review the PR sometime later this week and make a new release of the plugin. Would this mean no backwards compatibility of new versions of the plugin with older Nextflows (pre-April 2024)? https://github.com/fulcrumgenomics/nf-dotenv/pull/11/files
b
it's hard to say without testing the plugin. I have found that some plugins run just fine despite the version difference
c
I have a feeling mine does too (I think I've tested pre- post- 4.0 sufficiently). Would you recommend not moving to 4.0 if I didn't have to to increase backwards compatibility?
b
If you tested it and aren't seeing any issues, it might not be so urgent
👍 1