This message was deleted.
# helpdesk
s
This message was deleted.
f
Can you also post logs from egress? The logs from docker for egress. I am guessing that will be also be useful here.
a
I'm traveling today, but can look into this tomorrow - it's possible that the latest version no longer works locally, since we changed permissions and added sandboxing. If you want to get it working ASAP, you can try downgrading to a previous version
c
ok Thanks. let me try
how to download the previous version ?
i need to download the previous version of egress?
I have downgraded the version but now I am getting following error on egress service:
Copy code
2023-07-19T11:03:40.147+0530    ERROR   livekit service/ioinfo.go:76    egress failed   {"egressID": "EG_DdtUwPjRiZrz", "error": "chrome failed to start:\nFailed to move to new namespace: PID namespaces supported, Network namespace supported, but failed: errno = Operation not permitted\n[0719/053340.116225:ERROR:<http://file_io_posix.cc|file_io_posix.cc>(144)] open /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq: No such file or directory (2)\n[0719/053340.116292:ERROR:<http://file_io_posix.cc|file_io_posix.cc>(144)] open /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq: No such file or directory (2)\n"}
<http://github.com/livekit/livekit-server/pkg/service.(*IOInfoService).UpdateEgressInfo|github.com/livekit/livekit-server/pkg/service.(*IOInfoService).UpdateEgressInfo>
        /usr/local/bin/livekit/pkg/service/ioinfo.go:76
<http://github.com/livekit/psrpc/pkg/server.(*rpcHandlerImpl[...]).handleRequest|github.com/livekit/psrpc/pkg/server.(*rpcHandlerImpl[...]).handleRequest>
        /home/shgupta/go/pkg/mod/github.com/livekit/psrpc@v0.3.2/pkg/server/rpc.go:174
<http://github.com/livekit/psrpc/pkg/server.(*rpcHandlerImpl[...]).run.func1.1|github.com/livekit/psrpc/pkg/server.(*rpcHandlerImpl[...]).run.func1.1>
        /home/shgupta/go/pkg/mod/github.com/livekit/psrpc@v0.3.2/pkg/server/rpc.go:119
It seems chrome is not able to launch .. cpuld some help on this and give some insight why is it trying to launch chrome..
This is the error I am getting on egress server:
Copy code
essID": "EG_7EbaLc6zJzVi", "display": ":178824751", "dims": "1920x1080x24"}
2023-07-19T05:42:58.414Z        DEBUG   egress  source/web.go:174       launching chrome        {"nodeID": "NE_QBrGQraTcfvW", "handlerID": "EGH_2UuQRTgcmfu4", "clusterID": "", "egressID": "EG_7EbaLc6zJzVi", "url": "<http://localhost:7980/?layout=&token=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE2ODk4MzE3NzgsImlzcyI6ImRldmtleSIsIm5iZiI6MTY4OTc0NTM3OCwic3ViIjoiRUdfN0ViYUxjNnpKelZpIiwidmlkZW8iOnsiY2FuUHVibGlzaCI6ZmFsc2UsImNhblB1Ymxpc2hEYXRhIjpmYWxzZSwiY2FuU3Vic2NyaWJlIjp0cnVlLCJoaWRkZW4iOnRydWUsInJlY29yZGVyIjp0cnVlLCJyb29tIjoibXktZmlyc3Qtcm9vbSIsInJvb21Kb2luIjp0cnVlfX0.kALwTBpsA295rUPyjjz10-dBYoHA4WNrWF0j_HCUKpE&url=ws%3A%2F%2F192.168.65.254%3A7880>"}
2023-07-19T05:42:58.466Z        WARN    egress  source/web.go:68        failed to launch chrome {"nodeID": "NE_QBrGQraTcfvW", "handlerID": "EGH_2UuQRTgcmfu4", "clusterID": "", "egressID": "EG_7EbaLc6zJzVi", "display": ":178824751", "error": "chrome failed to start:\nFailed to move to new namespace: PID namespaces supported, Network namespace supported, but failed: errno = Operation not permitted\n[0719/054258.459664:ERROR:<http://file_io_posix.cc|file_io_posix.cc>(144)] open /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq: No such file or directory (2)\n[0719/054258.459712:ERROR:<http://file_io_posix.cc|file_io_posix.cc>(144)] open /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq: No such file or directory (2)\n"}
2023-07-19T05:42:58.481Z        WARN    egress  service/handler.go:198  egress failed   {"nodeID": "NE_QBrGQraTcfvW", "handlerID": "EGH_2UuQRTgcmfu4", "clusterID": "", "egressID": "EG_7EbaLc6zJzVi", "egressID": "EG_7EbaLc6zJzVi", "requestType": "room_composite", "outputType": "file", "error": "chrome failed to start:\nFailed to move to new namespace: PID namespaces supported, Network namespace supported, but failed: errno = Operation not permitted\n[0719/054258.459664:ERROR:<http://file_io_posix.cc|file_io_posix.cc>(144)] open /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq: No such file or directory (2)\n[0719/054258.459712:ERROR:<http://file_io_posix.cc|file_io_posix.cc>(144)] open /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq: No such file or directory (2)\n"}
f
Referring to older version of egress. You can find egress release tags here - https://github.com/livekit/egress/tags Please try v1.7.5 (git checkout v1.7.5) as that is the version prior to sandboxing.
c
it will resolve this chrome not launch error also ?
f
It should.
c
After running this command shall i run git checkout ?
Copy code
docker run --rm     -e EGRESS_CONFIG_FILE=/out/config.yaml     -v ~/livekit-egress:/out     livekit/egress
as when i run this command egress service started... like how to checkout older version then ?
f
If you are working locally, you wan to stop the egress service you are running ☝🏽 by Ctrl-C (kill the process), run
git checkout
to change your repo to v1.7.5, build egress again using
mage build
and then restart docker. If you are not familiar with git, please search for how to use git.
c
I hadn't checkout the egress code .. I am running is directly using the docker command
f
You can use image tag - https://docs.docker.com/engine/reference/run/#imagetag
Copy code
docker run --rm     -e EGRESS_CONFIG_FILE=/out/config.yaml     -v ~/livekit-egress:/out     livekit/egress:v1.7.5
c
yeahh with this command now not getting the chrome launchin error: Now this is the out put of egress service start
Copy code
2023-07-19T08:28:55.750Z        INFO    egress  service/service.go:114  request received        {"nodeID": "NE_AFZRhiLjXSSe", "clusterID": "", "egressID": "EG_g87VdiDJ2L7n"}
2023-07-19T08:28:55.752Z        INFO    egress  service/service.go:123  request validated       {"nodeID": "NE_AFZRhiLjXSSe", "clusterID": "", "egressID": "EG_g87VdiDJ2L7n", "request_type": "room_composite", "output_type": "file", "room": "my-first-room", "request": {"RoomComposite":{"room_name":"my-first-room","Output":{"File":{"filepath":"livekit/my-room-test.mp4","Output":{"S3":{"access_key":"{access_key}","secret":"{secret}","region":"aws-region","bucket":"my-bucket"}}}},"Options":null}}}
2023-07-19T08:28:55.812Z        DEBUG   egress  server/main.go:169      handler launched        {"nodeID": "NE_AFZRhiLjXSSe", "handlerID": "EGH_jvgQ9JBzSQiK", "clusterID": "", "egressID": "EG_g87VdiDJ2L7n"}
2023-07-19T08:28:55.813Z        INFO    egress  redis/redis.go:92       connecting to redis     {"nodeID": "NE_AFZRhiLjXSSe", "handlerID": "EGH_jvgQ9JBzSQiK", "clusterID": "", "egressID": "EG_g87VdiDJ2L7n", "simple": true, "addr": "192.168.65.254:6379"}
2023-07-19T08:28:55.886Z        DEBUG   egress  source/web.go:143       launching xvfb  {"nodeID": "NE_AFZRhiLjXSSe", "handlerID": "EGH_jvgQ9JBzSQiK", "clusterID": "", "egressID": "EG_g87VdiDJ2L7n", "display": ":725497761", "dims": "1920x1080x24"}
2023-07-19T08:28:55.887Z        DEBUG   egress  source/web.go:174       launching chrome        {"nodeID": "NE_AFZRhiLjXSSe", "handlerID": "EGH_jvgQ9JBzSQiK", "clusterID": "", "egressID": "EG_g87VdiDJ2L7n", "url": "<http://localhost:7980/?layout=&token=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE2ODk4NDE3MzUsImlzcyI6ImRldmtleSIsIm5iZiI6MTY4OTc1NTMzNSwic3ViIjoiRUdfZzg3VmRpREoyTDduIiwidmlkZW8iOnsiY2FuUHVibGlzaCI6ZmFsc2UsImNhblB1Ymxpc2hEYXRhIjpmYWxzZSwiY2FuU3Vic2NyaWJlIjp0cnVlLCJoaWRkZW4iOnRydWUsInJlY29yZGVyIjp0cnVlLCJyb29tIjoibXktZmlyc3Qtcm9vbSIsInJvb21Kb2luIjp0cnVlfX0.hdQdSTQKWH1svD7Ugb50HmJa2kgcRYBz9BK8G6fLXCE&url=ws%3A%2F%2F192.168.65.254%3A7880>"}
2023-07-19T08:28:56.796Z        DEBUG   egress  pipeline/pipeline.go:179        waiting for start signal        {"nodeID": "NE_AFZRhiLjXSSe", "handlerID": "EGH_jvgQ9JBzSQiK", "clusterID": "", "egressID": "EG_g87VdiDJ2L7n"}
2023-07-19T08:29:00.933Z        INFO    egress  source/web.go:252       chrome: END_RECORDING   {"nodeID": "NE_AFZRhiLjXSSe", "handlerID": "EGH_jvgQ9JBzSQiK", "clusterID": "", "egressID": "EG_g87VdiDJ2L7n"}
2023-07-19T08:29:00.988Z        DEBUG   egress  sink/file.go:58 removing temporary directory    {"nodeID": "NE_AFZRhiLjXSSe", "handlerID": "EGH_jvgQ9JBzSQiK", "clusterID": "", "egressID": "EG_g87VdiDJ2L7n", "path": "/tmp/lkegress/EG_g87VdiDJ2L7n/"}
2023-07-19T08:29:00.988Z        INFO    egress  service/handler.go:210  egress updated  {"nodeID": "NE_AFZRhiLjXSSe", "handlerID": "EGH_jvgQ9JBzSQiK", "clusterID": "", "egressID": "EG_g87VdiDJ2L7n", "egressID": "EG_g87VdiDJ2L7n", "request_type": "room_composite", "output_type": "file", "status": "EGRESS_ABORTED"}
And this is the server output:
Copy code
2023-07-19T13:58:55.757+0530    INFO    livekit service/twirp.go:128    API Egress.StartRoomCompositeEgress     {"service": "Egress", "method": "StartRoomCompositeEgress", "room": "my-first-room", "baseUrl": "", "outputType": "*livekit.RoomCompositeEgressRequest_File", "egressID": "EG_g87VdiDJ2L7n", "duration": "517.919358ms", "status": "200"}
2023-07-19T13:59:00.998+0530    INFO    livekit service/ioinfo.go:78    egress ended    {"egressID": "EG_g87VdiDJ2L7n"}
I am not sure if recording is scucccessful or not from this .. because i can't see the recorded file availble at the mentioned path.
This is the request.json I used
Copy code
{
  "room_name": "my-first-room",
  "file": {
    "filepath": "livekit/my-room-test.mp4",
    "s3": {
      "access_key": "devkey",
      "secret": "secret",
      "region": "aws-region",
      "bucket": "my-bucket"
    }
  }
}
it seems egress getting aborted.. but it is not mentioneing any reason why
a
add
--cap-add=SYS_ADMIN
to your run command
docker run --rm --cap-add=SYS_ADMIN -e EGRESS_CONFIG_FILE=/out/config.yaml -v ~/livekit-egress:/out livekit/egress:v1.7.5
c
ok. Thanks . Let me try it
no.. this is not working. still the egress is getting aborted
Copy code
2023-07-20T03:57:55.830Z        DEBUG   egress  pipeline/pipeline.go:179        waiting for start signal        {"nodeID": "NE_FgYWZtaaNWFp", "handlerID": "EGH_3umek7kA2hVs", "clusterID": "", "egressID": "EG_oJzKptybRwbY"}
2023-07-20T03:57:59.983Z        INFO    egress  source/web.go:252       chrome: END_RECORDING   {"nodeID": "NE_FgYWZtaaNWFp", "handlerID": "EGH_3umek7kA2hVs", "clusterID": "", "egressID": "EG_oJzKptybRwbY"}
2023-07-20T03:58:00.055Z        DEBUG   egress  sink/file.go:58 removing temporary directory    {"nodeID": "NE_FgYWZtaaNWFp", "handlerID": "EGH_3umek7kA2hVs", "clusterID": "", "egressID": "EG_oJzKptybRwbY", "path": "/tmp/lkegress/EG_oJzKptybRwbY/"}
2023-07-20T03:58:00.056Z        INFO    egress  service/handler.go:210  egress updated  {"nodeID": "NE_FgYWZtaaNWFp", "handlerID": "EGH_3umek7kA2hVs", "clusterID": "", "egressID": "EG_oJzKptybRwbY", "egressID": "EG_oJzKptybRwbY", "request_type": "room_composite", "output_type": "file", "status": "EGRESS_ABORTED"}
egress is just getting aborted .. but not showing the reason
even when listing all egress no error is being displayed there.
Copy code
EG_QDPSJtoXLVzV | EGRESS_ABORTED | 2023-07-19 14:50:11.424444118  |                                                        |
|                 |                | +0530 IST                      |
a
There is no
chrome: START_RECORDING
log. Aborted means
END_RECORDING
was called before it started, because the room was closed without anyone joining. This is not an error
Copy code
2023-07-20T03:57:55.830Z        DEBUG   egress  pipeline/pipeline.go:179        waiting for start signal        {"nodeID": "NE_FgYWZtaaNWFp", "handlerID": "EGH_3umek7kA2hVs", "clusterID": "", "egressID": "EG_oJzKptybRwbY"}
2023-07-20T03:57:59.983Z        INFO    egress  source/web.go:252       chrome: END_RECORDING   {"nodeID": "NE_FgYWZtaaNWFp", "handlerID": "EGH_3umek7kA2hVs", "clusterID": "", "egressID": "EG_oJzKptybRwbY"}
c
But my participant is joined in the room . I have joined 2 participants in that room . one with the generated token using cli and other with bot participant
using the following commands:
Copy code
./livekit-cli join-room \
    --url <ws://localhost:7880> \
    --api-key devkey --api-secret secret \
    --room my-first-room --identity bot-user \
    --publish-demo
	
./livekit-cli create-token     --api-key devkey --api-secret secret     --join --room my-first-room --identity user1     --valid-for 24h
a
is there poor connection? I cannot reproduce this, and all I can see from your logs is that the template is calling
END_RECORDING
Usually this happens when the last person leaves the room
d
Hi, I have encountered the same issue and fixed it like so. In egress config file "config.yaml", you must set an IP that is reachable from the inside of Docker container to reach Livekit server. It means for redis and ws_url your should have something like this:
Copy code
api_key: devkey
api_secret: secret
ws_url: <ws://172.17.0.1:7880>
redis:
  address: 172.17.0.1:6379
Do not use 127.0.0.1 cause it refers to Docker local internal instance. Hope it can help you @cold-belgium-91163 or anyone reading this post 😀
a