A while back our CF2018 production site started th...
# cfml-general
A while back our CF2018 production site started throwing a ton of errors that a specific cfm file many pages cfmodule to suddenly couldn't be found. No changes had been made to the server for a day and a half. I fixed it by restarting the CF service. I posted here about it at the time. Yesterday one specific page started throwing that same error, about the same cfmoduled-to file. A coworker reproduced it multiple times, while most of the site continued to run normally. The error didn't hit our normal CF error handling, and the page shown was a system/IIS 500 error page. He fixed it by clicking Reset Template Cache. Again nothing had changed on that server for days, not since 3/24. Has anyone seen anything similar? Any ideas of a cause, or a prevention strategy?
I've had some things randomly break on one of my 2018 Test servers, but when this happens, it seems like CF is unable create Java objects (
CreateObject("java", "whatever")
) which also means that the CF administrator becomes unavailable. So it doesn't sound really like the same thing, other than the complete randomness of it. A cf restart also fixes it, and I haven't been able to nail down a cause yet either.
Thanks @Tim, think you're right it's a different issue, but bleh. Some people in my organization aren't that impressed with CF, and stuff like this doesn't help.
One suggestion is that the module is being called using a path method (i.e. common/somepage.cfm). I have had this happen to me where the site seems to lose the pathing of the site (normally held by IIS or Apache). In order to fix this, I changed the call to /common/somepage.cfm and it worked. Also, if you have the path in an application variables, it may happen when the application variables expire and doesn't get re-created immediately. This happens (not all the time) but when I do Ajax calls where the application scope is somehow in the middle of being created and the call to the subdirectory is not quite complete.