https://pinot.apache.org/ logo
#pinot-dev
Title
# pinot-dev
s

saurabh dubey

04/06/2022, 10:16 PM
@User @User the master branch should compile just fine now. The required pom changes were merged recently. Beyond that, I just made sure I used the right jdk (official openjdk 11 isn't available as such for M1 yet, so had to use https://www.azul.com/downloads/?version=java-11-lts&os=macos&architecture=arm-64-bit&package=jdk). It compiled for me with this.
Also run
Copy code
softwareupdate --install-rosetta
https://github.com/grpc/grpc-java/issues/7690 settings.xml also needs to be changed
Copy code
vi ~/.m2/settings.xml
Copy
Copy code
<settings>
  <activeProfiles>
    <activeProfile>
      apple-silicon
    </activeProfile>
  </activeProfiles>
  <profiles>
    <profile>
      <id>apple-silicon</id>
      <properties>
        <os.detected.classifier>osx-x86_64</os.detected.classifier>
      </properties>
    </profile>
  </profiles>
</settings>
k

Kartik Khare

04/07/2022, 3:36 AM
This is the most important setting. Basically, what's happening here is that we are asking pinot to download x86_64 binaries for proto and grpc. The rosetta layer in M1 handles the translation for us to aarch_64.
s

saurabh dubey

04/08/2022, 10:19 AM
Adding to this, .snappy.parquet ingestion fails on M1 due to snappy-java dependency version being
Copy code
1.1.1.7
which fails with "org.xerial.snappy.SnappyError: [FAILED_TO_LOAD_NATIVE_LIBRARY] no native library is found for os.name=Mac and os.arch=aarch64" The solution should be to upgrade to 1.1.8.2 but I haven't been able to get it to work yet due to dependency conflicts but will update. https://github.com/xerial/snappy-java/blob/master/Milestone.md#snappy-java-1182-2020-11-28 As a workaround suggested by @User, using gzip instead of snappy for parquet compression works. cc: @User @User
14 Views