I am trying to setup a new pinot cluster. I have a...
# troubleshooting
y
I am trying to setup a new pinot cluster. I have a zookeeper cluster up. When I try to get the first pinot controller up, it gets up, and then fails with the an error
Copy code
Pinot Controller instance [Controller_piclx1001.hq.target.com_9000] is Started...
Started Pinot [CONTROLLER] instance [Controller_piclx1001.hq.target.com_9000] at 13.884s since launch
Shutting down Pinot Service Manager with all running Pinot instances...
Trying to stop Pinot [CONTROLLER] Instance [Controller_piclx1001.hq.target.com_9000] ...
Stopping controller periodic tasks
Stopping periodic task scheduler
.
.
Instance piclx1001.hq.target.com_9000 is not leader of cluster PinotCluster due to exception happen when session check
org.I0Itec.zkclient.exception.ZkInterruptedException: java.lang.InterruptedException
	at org.apache.helix.manager.zk.zookeeper.ZkClient.retryUntilConnected(ZkClient.java:1192) ~[pinot-all-0.9.0-SNAPSHOT-jar-with-dependencies.jar:0.9.0-SNAPSHOT-ffcf9b991431067c834bd4fb56fd7641c7fec172]
	at org.apache.helix.manager.zk.zookeeper.ZkClient.readData(ZkClient.java:1326) ~[pinot-all-0.9.0-SNAPSHOT-jar-with-dependencies.jar:0.9.0-SNAPSHOT-ffcf9b991431067c834bd4fb56fd7641c7fec172]
	at org.apache.helix.manager.zk.zookeeper.ZkClient.readData(ZkClient.java:1318) ~[pinot-all-0.9.0-SNAPSHOT-jar-with-dependencies.jar:0.9.0-SNAPSHOT-ffcf9b991431067c834bd4fb56fd7641c7fec172]
	at org.apache.helix.manager.zk.ZkBaseDataAccessor.get(ZkBaseDataAccessor.java:320) ~[pinot-all-0.9.0-SNAPSHOT-jar-with-dependencies.jar:0.9.0-SNAPSHOT-ffcf9b991431067c834bd4fb56fd7641c7fec172]
.
.
Closing zkclient: State:CONNECTED Timeout:30000 sessionid:0x1006d21ecf40000 local:/10.59.116.133:53916 remoteserver:<http://pizlx1002.hq.target.com/10.59.116.124:2181|pizlx1002.hq.target.com/10.59.116.124:2181> lastZxid:17179869383 xid:1154 sent:1157 recv:1199 queuedpkts:0 pendingresp:0 queuedevents:0
Session: 0x1006d21ecf40000 closed
j
Did you explicitly shut down the controller or it shuts down itself? The error happens after the shut down