has this setting `pinot.set.instance.id.to.hostnam...
# troubleshooting
m
has this setting 
pinot.set.instance.id.to.hostname
 changed in recent versions? Dones’t seem to be working any more and IPs are used instead
not only that, when I started a Pinot server, I got this error:
Copy code
2021/12/16 12:16:20.197 ERROR [StartServiceManagerCommand] [Start a Pinot [SERVER]] Failed to start a Pinot [SERVER] at 9.753 since launch
java.lang.RuntimeException: Cannot get localhost name
at org.apache.pinot.server.starter.helix.AdminApiApplication.setupSwagger(AdminApiApplication.java:127) ~[pinot-all-0.10.0-SNAPSHOT-jar-with-dependencies.jar:0.10.0-SNAPSHOT-fb12a509056b4e36724126cef9a344a5e1e89bb1]
at org.apache.pinot.server.starter.helix.AdminApiApplication.start(AdminApiApplication.java:107) ~[pinot-all-0.10.0-SNAPSHOT-jar-with-dependencies.jar:0.10.0-SNAPSHOT-fb12a509056b4e36724126cef9a344a5e1e89bb1]
at org.apache.pinot.server.starter.helix.BaseServerStarter.start(BaseServerStarter.java:426) ~[pinot-all-0.10.0-SNAPSHOT-jar-with-dependencies.jar:0.10.0-SNAPSHOT-fb12a509056b4e36724126cef9a344a5e1e89bb1]
at org.apache.pinot.tools.service.PinotServiceManager.startServer(PinotServiceManager.java:167) ~[pinot-all-0.10.0-SNAPSHOT-jar-with-dependencies.jar:0.10.0-SNAPSHOT-fb12a509056b4e36724126cef9a344a5e1e89bb1]
at org.apache.pinot.tools.service.PinotServiceManager.startRole(PinotServiceManager.java:97) ~[pinot-all-0.10.0-SNAPSHOT-jar-with-dependencies.jar:0.10.0-SNAPSHOT-fb12a509056b4e36724126cef9a344a5e1e89bb1]
at org.apache.pinot.tools.admin.command.StartServiceManagerCommand$1.lambda$run$0(StartServiceManagerCommand.java:276) ~[pinot-all-0.10.0-SNAPSHOT-jar-with-dependencies.jar:0.10.0-SNAPSHOT-fb12a509056b4e36724126cef9a344a5e1e89bb1]
at org.apache.pinot.tools.admin.command.StartServiceManagerCommand.startPinotService(StartServiceManagerCommand.java:302) [pinot-all-0.10.0-SNAPSHOT-jar-with-dependencies.jar:0.10.0-SNAPSHOT-fb12a509056b4e36724126cef9a344a5e1e89bb1]
at org.apache.pinot.tools.admin.command.StartServiceManagerCommand$1.run(StartServiceManagerCommand.java:276) [pinot-all-0.10.0-SNAPSHOT-jar-with-dependencies.jar:0.10.0-SNAPSHOT-fb12a509056b4e36724126cef9a344a5e1e89bb1]
Nvm, figured it out. It’s the DNS setting on the server.