This message was deleted.
# troubleshooting
s
This message was deleted.
k
Are you also capturing metrics emitted by your broker? Does the cpu or memory usage seem to be high?
g
i think exit code 3 can happen when the jvm exits due to OutOfMemoryError
(there may be other causes as well)
a
You can also run
kubectl logs ... -p
to get the logs from the previous execution of the the pod to see if there are any error messages associated with the exit.
d
This is why we deploy all of our daemons as StatefulSet. And thus, you can simply do
kubectl logs --previous
to see what bombed the daemon.
k
@kfaraz @Gian Merlino, indeed the memory usage is almost full for the container.
And looking at the logs from the previous run, indeed it is out of memory.
Copy code
kai.sun@kaisun-ltmtukn script % kubectl -n xxxx logs druid-monc-ra-common-lab1-brokers-0 -c druid-monc-ra-common-lab1-brokers --previous 
2022-11-01T03:36:49+0000 startup service broker
Setting druid.host=10.64.213.220 in /tmp/conf/druid/cluster/query/broker/runtime.properties
Terminating due to java.lang.OutOfMemoryError: Java heap space