This message was deleted.
# troubleshooting
s
This message was deleted.
k
What do the task logs say ?
a
interesting. @Didip Kerabat do you know if there was a major change preceding it? e.g. maybe an upgrade
d
Task logs didn’t say anything because it bombed earlier. As it turned out, the Kafka I am connecting to enforces authz via consumer group. After adding
group.id
in
consumerProperties
, it worked.
a
Nice. I am curious about how did it work. did you just set same group id (kafka-supervisor-xxx) in consumer properties?
d
yes, I just set the same
group.id
as what the Kafka team gave me.
a
I suppose that they also had to change some ACLs on their end.
was it a fresh cluster installation or an upgrade?
d
Fresh cluster install.
t
I see similar issue "errorMsg": "org.apache.kafka.common.errors.GroupAuthorizationException: Not authorized to access group: kafka-su...
how to fix this. Tried setting group.id in ingestion spec
d
how we fixed it is setting the
group.id
in the supervisor spec.
try testing on default Kafka CLI first and see.