Hey, does anyone have any ideas regarding what see...
# replication-troubleshooting
j
Hey, does anyone have any ideas regarding what seems like a permission issue during a BigQuery load:
Exception attempting to access the Gcs bucket
Stack Trace: com.amazonaws.services.s3.model.AmazonS3Exception: Access denied.
Service account currently has
"storage.multipartUploads.abort",
"storage.multipartUploads.create",
"storage.multipartUploads.list",
"storage.multipartUploads.listParts",
"storage.buckets.get",
"storage.buckets.create",
"storage.buckets.getIamPolicy",
"storage.buckets.list",
"storage.objects.create",
"storage.objects.get",
"storage.objects.getIamPolicy",
"storage.objects.list",
"bigquery.config.get",
Should be noted that Airbyte does actually manage to create and populate the buckets and items within GCS
b
Getting this strange error too. Seems like a permission issue strangely it mentions Amazon.
s
Hey @JP, @Benedikt Buchert, if you're still experiencing this issue could you share the full sync log? Also to answer the question in thread, Airbyte bucket config returns an S3 error because Airbyte is using the S3 API under the hood for bucket storage. Many storage providers including GCS use the S3 API and it has become somewhat standard. So don't worry, it isn't actually connecting to AWS here 🤔
thanku 1
b
Hi I solved the issue. It was the path for the blob storage that had a trailing slash. Removing that solved it for me.