Hi all, I sat up a postgres to bigquery connection...
# replication-troubleshooting
r
Hi all, I sat up a postgres to bigquery connection like this: https://airbyte.com/tutorials/postgres-to-bigquery and I wanted to extract data in an Incremental way and load it using Deduped + history mode. However, when I set it up like that I get the following message:
The form is invalid. Please make sure that all fields are correct.
Any idea what I'm doing wrong?
a
You need to select the cursor field for each incremental stream. https://glossary.airbyte.com/term/cursor/
✅ 1
@Andy Yeo (Airbyte) - assuming that the missing cursor is the reason the error message, it could probably give a more clear error message. Not sure which team handles that..
✅ 1
r
thank you Alex. I selected the cursor field, but I'm still getting an error when synching
Failure Origin: source, Message: Something went wrong in the connector. See the logs for more details.
I checked the logs, and I see it is because permission to the schema is denied. This is very surprising as I followed your guide here, and I tested your db without issues
also I get see the full details of the schema in airbyte
any idea what is going wrong?
a
It looks like the user and/or password you have defined in the connector may be having issues connecting to the source database
Perhaps you could go back to the source connector UI/definition and re-test the connection to the source.
r
I did re-test the connection and it doesn't give me an error
(it also doesn't give me a thumbs up) it just loads and then says re-test
So first I see this
When I press retest it loads this
and when it finishes loading I get this
I also checked in the db that the user that I'm using have access by running
Copy code
SELECT * FROM information_schema.table_privileges WHERE grantee='airbyte';
airbyte.png
a
are you definitely able to login to the database with the “airbyte” user and the password that you made use of in the source connector? (the test you did above validates the privileges, but not the password)
r
image.png
yes I'm pretty sure that I can
I also logged into the database using that account
however it does say that permission denied for the schema in the logs
image.png
a
yes, that looks like a different schema than what you validated above. What’s the result if you try reading the wawa schema from the airbyte user?
r
I just checked and my user can't access the schema
however, I don't know then how to give it access I ran the
Copy code
GRANT USAGE ON SCHEMA wawa TO airbyte
from a different user
and the command didn't fail
a
Have you tried granting SELECT ?
r
Yes! So I figured out that the user that I was granting access from didn't own the schema, so it couldn't do it (although it didn't give me an error when running the command) very confusing
thank you so much for you help !!!