I have some errors after installing the newest ver...
# replication-troubleshooting
r
I have some errors after installing the newest version of Airbyte:
Copy code
Caused by: io.temporal.failure.ApplicationFailure: message='SQL [select * from "public"."connection" where "public"."connection"."id" = cast(? as uuid)]; Error while reading field: "public"."connection"."unsupported_protocol_version", at JDBC index: 22', type='org.jooq.exception.DataAccessException', nonRetryable=false
and
Copy code
Caused by: org.postgresql.util.PSQLException: The column index is out of range: 22, number of columns: 21.
✅ 1
m
From what version to what version did you upgrade, can share the complete server logs?
r
I have managed to fix it with RUN_DATABASE_MIGRATION_ON_STARTUP =true config. My external RDS tables for airbyte did not have the airbyte user ownership. After transferring the ownership - problem was gone.
👍 1