I have a similar issue with a iOS device, I fixed it by adding the user agent strings like in the article described (
https://support.citrix.com/article/CTX554245/ios-cwa-add-url-failed-error-could-not-verify-server-address) but now I can login and after the login (SAML) I get a Error http/1.1 Internal Server Error 43524 or http/1.1 Internal Server Error 43531. And no I can reach the storefront and it does not matter if I use the IP or the dns name. 😉 On Workspace App for Windows everything works fine. There are no errors in the eventlog of storefront.