Hi team, we have seen this issue where CN consiste...
# questions-and-troubleshooting
t
Hi team, we have seen this issue where CN consistently failed to write cache
Copy code
W20251010 11:30:08.007740 140027330561600 cache_file.h:130] write star cache file data/07b82c61-baf8-4acb-9f6c-6b3669e414a6.sst failed, errmsg: INTERNAL: fail to write block because no valid cache space
but inside the CN nodes, I can see clearly there is plenty of space for cache to write
Copy code
Filesystem      Size  Used Avail Use% Mounted on
/dev/nvme1n1     98G   51M   98G   1% /opt/starrocks/be/storage
Could you help to see what might be the issue here?
k
the disk space is too small, diskcache will skip use this disk.
t
What do you mean the disk space is too small? We have 100G allocated, and you can see the /storage path is mounted correctly with only 1% used
datacache with cache size also have been specified
Copy code
datacache_enable = true
starlet_star_cache_disk_size_percent = 80
datacache_disk_size = 80%
@Kevin Cai also I could not find
cache_file.h
in starrocks repo, I guess this is the part where only binary is OSS atm? So currently I cannot dig into source code and debut this myself
k
which SR version are you on?
d
datacache_min_disk_quota_for_adjustment, change this to 10737418240, default is 100G, if disk is below 100G, disk cache will be skipped, change this to 10G, so you can use disk cache
t
starrocks 4.0 rc1