Hi, team. For loading data into Starrocks via Fli...
# questions-and-troubleshooting
t
Hi, team. For loading data into Starrocks via Flink connector, what kind of user role permissions need to be set? I have created the following role and granted the user for Flink
Copy code
GRANT SELECT, INSERT, UPDATE, DELETE ON <database>.* TO ROLE '<database>_writer';
GRANT '<database>_writer' TO '<user>';
SET DEFAULT ROLE '<database>_writer' TO '<user>';
still i get
Copy code
java.lang.IllegalArgumentException: Failed to get table schema info from StarRocks. Access denied for user '<user>' (using password: YES)
h
Have you tried starting with a user that has elevated privileges just like the root? If you are still in development env. From there, you can start removing a few privileges while testing to see which one works and which one once removed causes the errror.
t
I have already tested using root user and admin user creds, that's not the issue here. For production, the current setup is not possible, and nowhere in the documentation, there's any clarification on what exactly the permissions needed for the Flink connector itself. (The doc has mentioned, SELECT and INSERT should be granted for the user)
In terms of "removing previleges" I dont see how that is possible, since the only two things granted to the working version of the Flink connector user is • db_admin • user_admin I dont see how one can test removing priviledges from there
h
When is this error raised? The command you are running that raises this error. Is it when you run the job with sql-client script?
t
This error is raised from Flink sql-gateway, before the job was sent to job manager
I have tried to add
Copy code
GRANT SELECT ON information_schema.tables to ROLE '<database>_writer';
GRANT SELECT ON information_schema.columns to ROLE '<database>_writer';
but to no luck
The issue was that I was quoting a wrong password, instead of access issues. Somehow starrocks gives a AuthZ error, which should have been an Auth0 error