Hello All, Did anyone experienced `php_network_get...
# docker
r
Hello All, Did anyone experienced
php_network_getaddresses: getaddrinfo failed
issue while
docker/sdk bootstrap deploy.dev.yml
on WSL2?
Copy code
=> [stage-0  4/10] COPY --chown=spryker:spryker composer.json composer.lock /data/                                                                    0.1s
 => ERROR [stage-0  5/10] RUN --mount=type=cache,id=composer,sharing=locked,target=/home/spryker/.composer/cache,uid=1000     composer install --no-  36.9s
------
 > [stage-0  5/10] RUN --mount=type=cache,id=composer,sharing=locked,target=/home/spryker/.composer/cache,uid=1000     composer install --no-interaction --optimize-autoloader --no-dev:
#12 0.688 Loading composer repositories with package information
#12 0.694 Installing dependencies from lock file
#12 0.713 Package operations: 7 installs, 0 updates, 0 removals
#12 0.717   - Installing spatie/macroable (1.0.0): Downloading (failed)
#12 6.229 Downloading (failed)
#12 11.74 Downloading (failed)    Failed to download spatie/macroable from dist: The "<https://api.github.com/repos/spatie/macroable/zipball/74b0d189ce75142f1706aad834d5a428dfc7c3c3>" file could not be downloaded: php_network_getaddresses: getaddrinfo failed: Try again
#12 16.74 failed to open stream: php_network_getaddresses: getaddrinfo failed: Try again
#12 16.74     Now trying to download from source
#12 16.74   - Installing spatie/macroable (1.0.0): Cloning 74b0d189ce
#12 36.81
#12 36.81
#12 36.81   [RuntimeException]
#12 36.81   Failed to clone <https://github.com/spatie/macroable.git> via https, ssh protocols, aborting.
#12 36.81
#12 36.81   - <https://github.com/spatie/macroable.git>
#12 36.81     Cloning into '/data/vendor/spatie/macroable'...
#12 36.81     fatal: unable to access '<https://github.com/spatie/macroable.git/>': Could not resolve host: <http://github.com|github.com>
#12 36.81
#12 36.81   - git@github.com:spatie/macroable.git
#12 36.81     Cloning into '/data/vendor/spatie/macroable'...
#12 36.81     ssh: Could not resolve hostname <http://github.com|github.com>: Try again
#12 36.81     fatal: Could not read from remote repository.
#12 36.81
#12 36.81     Please make sure you have the correct access rights
#12 36.81     and the repository exists.
#12 36.81
#12 36.81
#12 36.81 install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...
#12 36.81
------
executor failed running [/bin/sh -c composer install --no-interaction --optimize-autoloader --no-dev]: exit code: 1
➖ 1
a
Seems like some local network/DNS problems.
h
using a proxy or VPN?
r
No proxy nor VPN. just a regular Win10 and WSL2 setup.
Btw, my
/etc/hosts
file seems to consist of incorrect IPs for
host.docker.internal
and
gateway.docker.internal
. Do you know what IPs should be used there?
Also, do you know what IP (or hostname) should be used in
/etc/resolv.conf
files?
An issue was resolved by resetting to factory defaults in Docker Desktop and re-exposing daemon.
👍 2
✅ 1