Hello engineers, It’s time again to talk about im...
# docker
p
Hello engineers, It’s time again to talk about improvements and fixes the Cloud team done in the releases: 1.16 - 1.18.2 Improvements: • Introduced Dashboard service for logs management. • Introduced support of ElasticSearch 7. • Adjusted cli containers with the possibility to use redis-cli. • Introduced the possibility to configure the FastCGI application port. The default FastCGI port is 9000. • Adjusted terraform frontend.json with a new zone parameter which contains the second-level domain name. • Introduced support for Tideways profiler. Bugfixes: • Fixed WebSockets support for services Web UIs. • Increased timeouts in Nginx and PHP for requests with XDebug. • Fixed wrong php/conf.d/90-opcache.ini location. • Fixed priority for opcache PHP configuration. • Adjusted providing env-variables into testing containers. Please, find more information here*:* • Releases: https://github.com/spryker/docker-sdk/releases • Docker SDK: https://documentation.spryker.com/installation/spryker_in_docker/docker_sdk/docker-sdk.htm And of course, please, try it and send us your feedback! Cloud team and Dmytro
7️⃣ 1
👍 1
m
Hi @plain-barista-64036 thank u for the improvements and bugfixes. I just updated my docker sdk and i got an error that zed rpc call does not work more..
Copy code
Spryker\Shared\ZedRequest\Client\Exception\RequestException - Failed to complete request with server authority <https://zed-docker.ebiz.loeffelhardt.de>.
            Configured with (SSL Enabled) <http://zed-docker.ebiz.loeffelhardt.de|zed-docker.ebiz.loeffelhardt.de>: in /data/config/Shared/config_default.php. Error: Stacktrace
Is it maybe something new to take care or maybe a bug?
I will check the vhost file... because just seen that backend url just reply 502 bad gateway
vhost files with new timeouts.conf.twig seems to be ok..
@average-branch-45579 any idea?
I just configured the new dashboard services and i see that there is this error in nginx:
Copy code
[proxy] [frontend] - 2020/08/17 15:00:40 [error] 9#9: *10 upstream sent too big header while reading response header from upstream, client: 172.24.0.18, server: <http://zed-docker.ebiz.loeffelhardt.de|zed-docker.ebiz.loeffelhardt.de>, request: "GET /auth/login?referer=%2Fauth%2Flogin%3Freferer%3D%252Fauth%252Flogin%253Freferer%253D%25252Fauth%25252Flogin%25253Freferer%25253D%2525252Fauth%2525252Flogin%2525253Freferer%2525253D%252525252Fauth%252525252Flogin%252525253Freferer%252525253D%25252525252Fauth%25252525252Flogin%25252525253Freferer%25252525253D%2525252525252Fauth%2525252525252Flogin%2525252525253Freferer%2525252525253D%252525252525252Fauth%252525252525252Flogin%252525252525253Freferer%252525252525253D%25252525252525252Fauth%25252525252525252Flogin%25252525252525253Freferer%25252525252525253D%2525252525252525252Fauth%2525252525252525252Flogin%2525252525252525253Freferer%2525252525252525253D%252525252525252525252Fauth%252525252525252525252Flogin%252525252525252525253Freferer%252525252525252525253D%25252525252525252525252Fauth%25252525252525252525252Flogin%25252525252525252525253Freferer%25252525252525252525253D%2525252525252525252525252Fauth%2525252525252525252525252Flogin%2525252525252525252525253Freferer%2525252525252525252525253D%252525252525252525252525252Fauth%252525252525252525252525252Flogin%252525252525252525252525253Freferer%252525252525252525252525253D%25252525252525252525252525252Fauth%25252525252525252525252525252Flogin%25252525252525252525252525253Freferer%25252525252525252525252525253D%2525252525252525252525252525252Fauth%2525252525252525252525252525252Flogin%2525252525252525252525252525253Freferer%2525252525252525252525252525253D%252525252525252525252525252525252Fauth%252525252525252525252525252525252Flogin%252525252525252525252525252525253Freferer%252525252525252525252525252525253D%25252525252525252525252525252525252Fauth%25252525252525252525252525252525252Flogin%25252525252525252525252525252525253Freferer%25252525252525252525252525252525253D%2525252525252525252525252525252525252Fauth%2525252525252525252525252525252525252Flogin%252525252525252525252525
It seems that there is an infinitive redirect and then stopped by server self...
a
No, I have no ideas. Latest master works for me flawlessly.
h
I assume that is wrong configuration on project level. Is this problem for Zed BO or Zed Gateway or both?
m
I figured out that the problem was located in Zed EventDispatcher. Maybe sort of registered plugins. Now it works again
👍 1