Hi all, I am trying to install Spryker B2B with d...
# docker
a
Hi all, I am trying to install Spryker B2B with docker … everything seems to be going well until it tries to run installation recipe I get this error … Any suggestions ? where can I see the logs … because even when I try to read containers logs I don’t seem to find them (or not anything useful)
s
It seems to be a compatibility problem of the current images and node. Please take a look at the post of Sarah Baumann, a few days ago. It was already discussed there
❤️ 1
✅ 2
s
One way you can resolve this is by pulling in the latest versions of both
node-sass
and
@spryker/oryx-for-zed
using a
docker/sdk cli npm install ...
command line. That should do the trick. Otherwise refer to the post by Sarah.
a
i tried to change php image version as mentioned by @high-pencil-62400 but now I get a different error (again with npm)
I think I will try to revert the changes and check your suggestion @powerful-oyster-48938
a
Wrong Thomas. 😄
a
hehe sorry
😅
I get this error here
I deleted all the images and containers and restarted and it seems to work now
I added the hostnamse to the hosts file
but I cannot access Yves
am I missing something?
s
That makes sense because your setup never started.
It aborted in one of the pre-steps.
👍🏻 1
it's also in a broken state right now
so to mangle your way through this:
docker-compose -f docker/deployment/default/docker-compose.yml up -d
after that the docker/sdk cli command I mentioned
(npm)
then after that - important - docker/sdk reset
ah ok. weird.
a
after I deleted all the images and containers I ran
boot
again and then
up
which started docker environment
I can see now all containers that deploy.dev.yaml describes
the only issue at the moment I think is that I cannot access the app 😅
h
The primal issue was incompatibility with alpine 3.12 and outdated sass npm module
a
I updated php image so now it is
Copy code
image: spryker/php:7.2-alpine3.10
👍 1
h
So for the history: The options are: • use apline3.10 image: spryker/php7.3-alpine3.10 (or what PHP version do you use) • Upgrade oryx to 2.6.0
a
Installation passed successfully so I assume the original issue is resolved … now the servers are running but I cannot access them
oh oh wait
i was trying to access with https
with http it works
❤️
thank you all