Hi guys, does anyone have experience with this err...
# docker
m
Hi guys, does anyone have experience with this error:
Service search is not running. Please check the name.
? I have under service/elastic the default version of elastic to 6.8 changed, because i need this version. Thanks in advance
q
@brave-article-83943 maybe? 😊
m
normally the last commit https://github.com/spryker/docker-sdk/commit/ec491a7e9123ce7fee3d87ae7cfa992556c455d1 provide the compatibility to elastic 6.8 based on new search-elasticsearch bundle.
a
ES6+ support isn't ready yet and will be ready (documentation, integration\migration guides and vagrant+docker readiness) together with an upcoming product release which is going to happen after the New Year if everything is ok.
m
@average-branch-45579 ok, but it works already (on vagrant). Why is not ready yet, but releases as stable package (1.0.0) ?
a
The whole epic contains not only module but also documentation and development environment. Neither documentation nor development envs (vagrant contains both versions of ES but 5 is still default) are not ready yet.
m
yes, u are right. But there are a lot of modules without documentation etc... therefore for me when something is released as stable version it means that we can use it... clear... our problem.... normally i can also wait until next year of product release... but for the devs that have a application based on suite, they have don't to wait of any product release.. today if i want take up the actual spryker-shop/suite with docker and ES6+ it does not work... at least on my env..
a
The code works with both versions of ES. The only thing that left is dev env. And mentioned commit is only about documentation and not the actual support of ES6+. Sorry, our development team pushed the doc. part earlier then the actual support.
p
Hi Giovanni, Sorry for this bad experience. We are going to fix this bug. Thank you for reporting it!
m
Thanks both @average-branch-45579 and @plain-barista-64036 i try with ES5.6 at first... please let me know when it is fixed.
h
Hi Giovanni, Would you be so kind to dump the ES part of your
deploy.yml
file?
m
Hi Mike, do u mean this (from deploy.dev.yml)
Copy code
search:
        engine: elastic
        version: 6.8
I just now reverted back (without version) and per default docker compose use the default version 5.6 and everything seems to be loaded/created/running
h
ok. That’s correct. Please try to run again and check if container is running.
docker ps | grep search
I assume that ES6 cannot run with data volume created by ES5.
m
ok, i try to give a feedback in 10 min.. i have now a meeting
h
If container is not running.
docker logs spryker_search_1
would give the output
Sure.
m
docker ps | grep search
is empty...
docker logs spryker_search_1
-> no such container: spryker_search_1
docker logs spryker_b2b_dev_search_1
-->
Copy code
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
[2019-12-17T14:05:39,538][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [unknown] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/share/elasticsearch/data]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.8.4.jar:6.8.4]
	at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:116) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.8.4.jar:6.8.4]
Caused by: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/share/elasticsearch/data]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
	at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:300) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.node.Node.<init>(Node.java:296) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.node.Node.<init>(Node.java:266) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:212) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:212) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-6.8.4.jar:6.8.4]
	... 6 more
Caused by: <http://java.io|java.io>.IOException: failed to obtain lock on /usr/share/elasticsearch/data/nodes/0
	at org.elasticsearch.env.NodeEnvironment$NodeLock.<init>(NodeEnvironment.java:218) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:270) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.node.Node.<init>(Node.java:296) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.node.Node.<init>(Node.java:266) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:212) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:212) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-6.8.4.jar:6.8.4]
	... 6 more
Caused by: java.nio.file.AccessDeniedException: /usr/share/elasticsearch/data/nodes/0/node.lock
	at sun.nio.fs.UnixException.translateToIOException(UnixException.java:90) ~[?:?]
	at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111) ~[?:?]
	at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116) ~[?:?]
	at sun.nio.fs.UnixFileSystemProvider.newFileChannel(UnixFileSystemProvider.java:182) ~[?:?]
	at java.nio.channels.FileChannel.open(FileChannel.java:292) ~[?:?]
	at java.nio.channels.FileChannel.open(FileChannel.java:345) ~[?:?]
	at org.apache.lucene.store.NativeFSLockFactory.obtainFSLock(NativeFSLockFactory.java:125) ~[lucene-core-7.7.2.jar:7.7.2 d4c30fc2856154f2c1fefc589eb7cd070a415b94 - janhoy - 2019-05-28 23:30:25]
	at org.apache.lucene.store.FSLockFactory.obtainLock(FSLockFactory.java:41) ~[lucene-core-7.7.2.jar:7.7.2 d4c30fc2856154f2c1fefc589eb7cd070a415b94 - janhoy - 2019-05-28 23:30:25]
	at org.apache.lucene.store.BaseDirectory.obtainLock(BaseDirectory.java:45) ~[lucene-core-7.7.2.jar:7.7.2 d4c30fc2856154f2c1fefc589eb7cd070a415b94 - janhoy - 2019-05-28 23:30:25]
	at org.elasticsearch.env.NodeEnvironment$NodeLock.<init>(NodeEnvironment.java:211) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:270) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.node.Node.<init>(Node.java:296) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.node.Node.<init>(Node.java:266) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:212) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:212) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) ~[elasticsearch-6.8.4.jar:6.8.4]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-6.8.4.jar:6.8.4]
	... 6 more
h
docker volume rm spryker_b2b_search-elastic-data
please make sure the volume name is correct
Also everything should be down before
m
yes... it works now... thanks.. it means that in the case i want to switch back to ES5.x i have to remove every time the volume?
@high-pencil-62400 some experience with this other error?
Copy code
==> /var/log/spryker/DE/YVES/exception.log <==
[2019-12-17 14:16:59] Yves.CRITICAL: ErrorException - ini_set(): session.name cannot be a numeric or empty '' in "/data/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php::389" {"exception":"[object] (ErrorException(code: 0): ini_set(): session.name cannot be a numeric or empty '' at /data/vendor/symfony/http-foundation/Session/Storage/NativeSessionStorage.php:389)
[stacktrace]
h
It seems yes. We do not assume data migrations in dev mode.
According error - no clue. Probably wrong configuration.
please ask in #help
m
ok.. but i just dont change anything.. the actual configuration works very well in vagrant env..
ok, i ll try.. thanks