@here Has anyone had this bug?
# help
a
@here Has anyone had this bug?
p
Heyhey @acoustic-terabyte-93857, welcome to the Spryker world 👋 based on your screenshots everything seems to be fine. Have you double checked the hosts file? One additional wish: If you post other questions in the future, please try to post them in one message or continue in the thread. With this it is easier to follow up on that 🙂 When you type in
docker/sdk install
is there any output about the hosts -file?
👍 1
And also please post your question just in one channel 😛
a
hi @plain-city-95899 the hosts file added. Issue resolve by change syntax confix nginx http2
p
Glad that you could solve it 💪 yet i am curious what you changed? - Because there should be no change needed from the dev environment. It should work as it is without the need of touching any file. What exactly did you do in order to make it work for you?
a
change file gateway.default.conf
p
i will try to reproduce, thx
🙌 1
👀 1
a
Great, thanks
p
If you have time today - could you revert your changes and try it again? - because based on the post your linked it should not impact the container. and also a Spryker dev checked on linux and he could not reproduce it either. Could it be that maybe a port was already taken?
a
Could it be that maybe a port was already taken? => I had this issue and stopped external services
I tried but still can't.
p
What about this here? - this one i do not have. the “warn” should not do anything. Based on my research and also on the thread you linked it is just a deprecation. Have you checked if any port is occupied after you did
docker/sdk down
? (https://www.cyberciti.biz/faq/unix-linux-check-if-port-is-in-use-command/)
i am so behind this because if you change files in the docker folder these will not be tracked via git and you have to apply the changes again and again in the future
but the port theory should also fail with your fix…
a
hi @plain-city-95899, I can see the cause has been found. Because Ipv6 has been disabled
There is another issue when accessing http://glue.at.spryker.local/ or http://glue.de.spryker.local/ it outputs the error {"errors":[{"status":404, "detail":"Not Found"}]} Is this a bug?
p
ahhh, i had a feeling about ipv6 (because the one part of your error mentioned it) but i have too few knowledge there. - glad that you found it! 💪 Overall your videos for step-by-step guide were wonderful and gave a huge insight about the problem!
btw, i reported internal anyway the deprecation warning so the team can cover it in the next months.
There is another issue when accessing http://glue.at.spryker.local/ or http://glue.de.spryker.local/ it outputs the error {“errors”[{“status”404, “detail”:“Not Found”}]}
Is this a bug?
This is not a bug -> there is simply no route defined for “/” out-of-the-box. Have a look at swagger.spryker.com to see documented endpoints.
a
thanks you @plain-city-95899