Georg Keferböck
07/21/2025, 9:13 PMAlex P
07/31/2025, 5:21 PMGeorg Keferböck
08/07/2025, 3:05 PMtvdeyen
Alex P
09/08/2025, 8:11 PMSpree::ShippingMethod for the shipping providers in the quote, and add it to the customer’s Spree::Zone if necessary. I also have a custom ShippingCalculator that uses the POD quote to check for availability and cost.
I’m seeing some odd behaviour when I’m off the “happy path”, though, such as when the line items change in an order, or a customer revives an older order. My “choose delivery” page displays all the current_order.shipments.last.shipping_rates, but these aren’t lining up with the data in my POD quote. I think this is because they’re remnants from a previous quote.
I can call #refresh_rates on my shipment whenever I’m on the delivery page, and that gets me part of the way there. (It adds missing `ShippingMethod`s, but doesn’t remove obsolete ones. And I don’t think it adjusts the cost either). But I suspect there’s a more idiomatic/more comprehensive way of achieving this. Does anyone have any pointers?m b
09/09/2025, 9:25 AMIbrahim salem
09/09/2025, 9:30 AMm b
09/09/2025, 9:34 AMIbrahim salem
09/09/2025, 9:47 AMIbrahim salem
09/09/2025, 9:48 AMm b
09/09/2025, 9:51 AMDoug DeBold
09/17/2025, 9:07 PMSlackbot
09/29/2025, 2:08 AMAlex P
10/18/2025, 6:38 PMOrder as complete. In my test I’m constructing an order_ready_to_complete, and I’ve checked that my mock webhook payment is for more than the order total. And yet! Calling order.complete in my controller isn’t marking the order as `complete`; order.can_complete? returns false. How can I find out what’s preventing completion of this order?1Maskhal
10/24/2025, 8:41 AMDoug DeBold
10/31/2025, 2:36 AMspree.api_order_path), and the update checkout path (spree.api_checkout_path). It seems that the checkout API has some limitations like if the order is on the payment step, you can't change the address and I haven't found a nice way to move the order backwards through the state machine.
What is the recommended use of these APIs in a checkout flow?1Maskhal
11/01/2025, 1:32 PMVinicius Tinti de Paula Oliveira
11/10/2025, 1:25 PM(store):19:in '<main>': Attach interfaces using `implements(GraphQL::Types::Relay::Node)`, not `include(GraphQL::Types::Relay::Node)` (RuntimeError)
This is my current setup:
* solidus (4.6.0)
* solidus_admin (0.4.0)
* solidus_api (4.6.0)
* solidus_auth_devise (2.5.9)
* solidus_backend (4.6.0)
* solidus_core (4.6.0)
* solidus_graphql_api (0.3.1)
* solidus_legacy_promotions (4.6.0)
* solidus_sample (4.6.0)
* solidus_support (0.14.1)
* RUBY_VERSION=3.4.5
* RAILS_VERSION=8.0.3Alistair Norman
11/12/2025, 5:33 AMSlackbot
02/18/2026, 10:36 PMjx
03/09/2026, 2:51 PM$rails new my_project
$bundle add solidus
$bin/rails g solidus:install
~/.local/share/gem/ruby/gems/bundler-4.0.7/lib/bundler/runtime.rb:71:in 'block (2 levels) in Bundler::Runtime#require': There was an error while trying to load the gem 'solidus'. (Bundler::GemRequireError)
Gem Load Error is: Could not open library '/home/idk/.local/share/gem/ruby/gems/sassc-2.4.0/ext/libsass.so': /home/idk/.local/share/gem/ruby/gems/sassc-2.4.0/ext/libsass.so: cannot open shared object file: No such file or directory.
I have tried changing Rails versions and installing libsass and its dev package to my machine and refreshing the sassc gem.
The error happens on bin/rails g solidus:install.Dennis Paagman
03/23/2026, 1:30 PMAdrian Paluch
07/15/2026, 9:42 AMcanonical-rails still a dependency of Solidus?
I’m trying to upgrade my application from Rails 7.1.3 to Rails 8.1 (and Solidus v4.7), but Bundler cannot resolve dependencies because canonical-rails 0.2.17 depends on actionview < 8.1.
Is there a recommended upgrade path for Solidus applications targeting Rails 8.1, or is support for a newer version of canonical-rails planned?Adrian Paluch
07/16/2026, 7:31 PMbundle add solidus
IT WAS OK
rails generate solidus:install --help
/Users/adrian/.rbenv/versions/4.0.1/lib/ruby/gems/4.0.0/gems/sprockets-rails-3.5.2/lib/sprockets/railtie.rb:106:in 'block in <class:Railtie>': Expected to find a manifest file in `app/assets/config/manifest.js` (Sprockets::Railtie::ManifestNeededError)
But did not, please create this file and use it to link any assets that need
to be rendered by your app:
Example:
//= link_tree ../images
//= link_directory ../javascripts .js
//= link_directory ../stylesheets .css
and restart your server
For more information see: <https://github.com/rails/sprockets/blob/070fc01947c111d35bb4c836e9bb71962a8e0595/UPGRADING.md#manifestjs>
from /Users/adrian/.rbenv/versions/4.0.1/lib/ruby/gems/4.0.0/gems/railties-8.1.3/lib/rails/initializable.rb:24:in 'BasicObject#instance_exec'
from /Users/adrian/.rbenv/versions/4.0.1/lib/ruby/gems/4.0.0/gems/railties-8.1.3/lib/rails/initializable.rb:24:in 'Rails::Initializable::Initializer#run'
from /Users/adrian/.rbenv/versions/4.0.1/lib/ruby/gems/4.0.0/gems/railties-8.1.3/lib/rails/initializable.rb:103:in 'block in Rails::Initializable#run_initializers'Adrian Paluch
07/17/2026, 10:15 AMconfig.assets.css_compressor = nil in test.rb file...
321 examples, 81 failures, 1 pendingAdrian Paluch
07/20/2026, 8:57 PMsolidus_importer still requires Ruby 2.5? I can see relatively fresh code updates in this gem from 9 months ago, so I was expecting it to be compatible with newer Ruby versions.
Running:
bundle install
Fetching gem metadata from <https://rubygems.org/>........
Resolving dependencies...
Could not find compatible versions
Because every version of solidus_importer depends on Ruby ~> 2.5
and Gemfile depends on solidus_importer >= 0,
Ruby ~> 2.5 is required.
So, because current Ruby version is = 4.0.1,
version solving has failed.
Is this expected, or am I missing something?
I appreciate the work that goes into maintaining open-source projects — I'm just trying to understand the current compatibility requirements and whether I'm missing something.
EDIT!!
Ok, using gem 'solidus_importer', github: 'solidusio-contrib/solidus_importer' did the job, thanks (but I'm not sure why)Jared Norman
Donutedits
07/24/2026, 12:18 PMbenjaminwil
09/03/2026, 10:30 PMbin/sandbox, the sandbox is being created as expected. however, when i try to run bin/dev or bin/rails server afterwards it tells me that i need to run bundle install first:
bin/rails server
Running Rails from: /home/bw/solidus/sandbox
<https://github.com/solidusio/solidus_paypal_commerce_platform.git> is not yet checked out. Run `bundle install` first.
based on the contents of the sandbox script, it seems to me that i shouldn't have to bundle install again.
just curious if this is a "just me" problem or a historic problem with the sandbox script.
if someone has time to try running bin/sandbox, ensure it succeeds, and then bin/rails server and report whether it works or whether you need to bundle install, i would be grateful!benjaminwil
09/14/2026, 6:37 PMsolidus_admin are missing some configuration, but i'm not positive. when i enabled artifact uploading for failed feature tests, the screenshots look unstyled (example attached).
the test failure i'm focused on also indicates that a "Product was successfully updated." toast is not appearing after a POST request, even though i see it happening consistently locally.
so this all makes me think we're missing something. currently looking into it further to verify, but if anyone has any ideas i'd love to hear them.