I have a project that deploys through <#C01UJ8MDHE...
# seed
I have a project that deploys through #seed which builds a container and pushes to ECR. The dockerfile pulls in (the latest) code from a git library we use into the image. We observe that even when we make changes to our git library and rerun the #seed deployment, it does not update the ECR image because (I am assuming) the Dockerfile has not changed, and so it uses a cached image. What’s the best approach to force a rebuild of the container?
I tried setting
Copy code
check_code_change: false
but that didn’t seem to do anything
Hey @Guy Shechter, can you DM me a link to the build on SEED?
Will do. I ended up doing this, and it seemed to force it:
Copy code
taskDefinition.addContainer('containerName', {
          image: ecs.ContainerImage.fromAsset('src/', {
            file: options.dockerfile,
            buildArgs: {
              DUMMY_DATE: Date()     <-----
Oh I see.
I’m looking at ur build log, if I expand the
INFO: Publishing assets...
fold, I see a couple docker images being built. Do you mean it’s not using the latest git library?
v9 & v10 worked with the change I put above, but v8 e.g. did not generate a new image on ECR