I am getting the following error suddenly when try...
# seed
I am getting the following error suddenly when trying to deploy manually via SEED:
[dev-ticket-exporter-sfn/JobStateMachine/Role/DefaultPolicy] A PolicyStatement used in an identity-based policy must specify at least one resource.
I haven't changed any of the policies or permissions for anything in my step function stack and it's just randomly started happening, does anyone have any ideas?
@Frank Apologies but would you be able to offer any insight on this? I really am stumped as I've not made any changes to the policies or permissions
Even when trying to redeploy older commits that successfully deployed it is now erroring, I'm thinking there have been aws-cdk changes? The file that validates policy statements was updated 2 days ago
hey @Jack G, r u getting this error on the build or deploy step? Can you share a screenshot of the build log maybe?
Sure! Here's a screen from the build log, it looks like it's happening during build?
Do u get the same error if u try to run
sst build
Nope, sst build works fine!
Sorry @Frank were you able to think of anything that might be causing this? Or would you be able to tag anyone who might know?
@Jack G sorry about the late follow up. After you run
sst build
, can you go into the
folder and DM the
, and the
Hey @Jack G I cross checked the build log and the files you sent me, and I noticed there are some version mismatch in the SST packages.
Can you open up ur package.json and set these versions:
Copy code
"@serverless-stack/cli": "0.64.0",
"@serverless-stack/resources": "0.64.0",
"aws-cdk-lib": "2.15.0",
All without the
infront of the version.
Then, run
npm/yarn install
> commit the updated lock file > git push to trigger a new deploy.
Let me know how it goes.
That seems to have fixed it @Frank! Many many thanks for taking the time to investigate this