Alright, my first issue was solved by pinning ever...
# seed
Alright, my first issue was solved by pinning everything at the version I needed (which I should have gotten from the docs), and the second issue was thinking you could have a seed.yml file for each service instead of it being global. I’ve got the seed file to run and attempt to install my deps, however I am getting this error I’m not sure how to resolve:
Copy code
npm ERR! code EEXIST
npm ERR! syscall symlink
npm ERR! path ../lib/node_modules/serverless/bin/serverless.js
npm ERR! dest /usr/local/bin/serverless
npm ERR! errno -17
npm ERR! EEXIST: file already exists, symlink '../lib/node_modules/serverless/bin/serverless.js' -> '/usr/local/bin/serverless'
npm ERR! File exists: /usr/local/bin/serverless
npm ERR! Remove the existing file and try again, or run npm
npm ERR! with --force to overwrite files recklessly.
I’m wondering if it has to do with a failed delete of the same app (not sure why it won’t delete, the only cloudformation stacks it created was the one for the IAM user)
I just added
for now to get past this