Hey everyone! I'm a newbie on sst, and some things...
# help
Hey everyone! I'm a newbie on sst, and some things are still not clear to me... I've been trying to create a simple Lambda function without any event (it will be invoked by SES as part of a ruleset...) I tried doing this:
Copy code
import * as sst from "@serverless-stack/resources";

export default class MtSStack extends sst.Stack {
  constructor(scope, id, props) {
    super(scope, id, props);

    const spamCheck = new sst.Function(this, "SpamCheck", {
      handler: "src/spamCheck.handler",

      FunctionArn: spamCheck.functionArn,
But keep getting some issues on start/deploy:
Copy code
prod-mts-sst-app-debug-stack | CREATE_FAILED | AWS::Lambda::Function | Connect5B7625CA Template error: IAM role prod-mts-sst-app-debug-st-ConnectServiceRole07B61C-6GL2GT2QJTIS doesn't exist
prod-mts-sst-app-debug-stack | CREATE_FAILED | Custom::S3AutoDeleteObjects | BucketAutoDeleteObjectsCustomResourceBAFD23C2 
prod-mts-sst-app-debug-stack | CREATE_FAILED | AWS::Lambda::Function | Resource 
prod-mts-sst-app-debug-stack | CREATE_FAILED | AWS::Lambda::Function | Disconnect7D6B12BD
Any ideas of how to get it working?
Did you delete anything from the AWS console?
Can you try going to cloud formation screen and deleting the prod-mts-sst-app-debug-stack and redeploying
didn't work as well... soemthing off with my config... started giving trouble after I renamed
from the template to
I have it working now on a fresh project...
Thank you
Same issue here, all of the sudden I can't
npx sst start
. What did you do to resolve it?
i couldn't... luckly it was a new and simple project, so I just recreated it in fresh sst app
Hm I'm not entirely sure @Frank any ideas?
No issues with bootstrapping just the debug stack.
I dont think it's an issue with 40.2 as I've redeployed fine earlier today.
Wasn't there a aws-cdk update today? Maybe that changed something.
Just tried now, and debug stack works.
Did you update to a different cdk? sst requires a specific version (currently 1.114.0)
No, all my versions are correct. It's strange because it all works now. Not sure what the cause was maybe AWS problem.
@Daniel da Rocha @Hubert AWS had some issue with their IAM service. I think that’s likely what caused the issue https://status.aws.amazon.com
Indeed, I confirm it is working normally now!! Thanks...