YIKES HELP? Anyone every experience constructs not...
# help
YIKES HELP? Anyone every experience constructs not autocompleting and erroring as (
Property 'DeliveryStream' does not exist on type 'typeof...node_modules/@aws-cdk/aws-kinesisfirehose/lib/index
) and not appearing when editing.
I had this working two seconds ago. I’ve ensured all packages are same version and even ran>..
npx sst update
Just noticed that even though I only installed certain modules of CDK…. it appears ALL have been installed under the
namespace? This isn’t what I expected at all… what is going on?
Dead in the water. I have not idea how to fix. I’ve so far… • deleted node_modules folder and reinstalled • removed and added the specific modules with
npx sst add-cdk
• closing VSCode and reopening I can’t get
to appear under
whats more odd to me is that I can remove all
@aws-cdk ...
from my package json… and yet ALL of them appear in node modules. Perhaps this last is simply because
? Please help if you have any ideas… I’ve never been so stuck before. gah~
@Frank @thdxr Either of you able to help sort me out? Completely stuck here. Even tried creating a brandnew SST app in a different dir and I’m getting the same result. I’m betting this is going to be super simple and stupid…. but I can’t see it.
Sorry at lunch right now let me take a look
oh sorry man…. thanks for any help you can give
Can you blow away node_modules and reinstall
yup did that 3x now
I’ll do again
happening on a fresh SST app/directory too…
That is really strange
Do you have any node_modules folders in the parent directories?
let me push up to public repo and see if you can reproduce
oh…. my….. gawd….
I bet that is it
sigh…. ok so there WAS a node_module folder in my
folder, which is where all my repos are cloned into. Not sure how it got there…. but its gone now… deleted…. I then went back into the fresh SST app removed node_modules folder there as well and reinstalled still no dice
I’m I on glue….. there is a
construct under
@thdxr here is the repo to test https://github.com/iDVB/my-sst-app just need to uncomment line 9 and see if it recognizes
for you.
This seems to be specific to this single module though…. so could be I’m using it wrong? Weird part is that this WAS working like 2mins earlier from when I started having the issue today.
lol I have the same issue, one sec
ok so it looks like
All classes with the Cfn prefix in this module (CFN Resources) are always stable and safe to use.
The APIs of higher level constructs in this module are experimental and under active development. They are subject to non-backward compatible changes or removal in any future version. These are not subject to the Semantic Versioning model and breaking changes will be announced in the release notes. This means that while you may use them, you may need to update your source code when upgrading to a newer version of this package.
I think the higher level ones aren't available in 1.114 which is what sst supports right now
hmm…. ok… that makes sense… what does that mean for us if we want to use kinesis firehose? Is there another L2 contruct for them? I didnt realize this wasn’t the primary construct for firehose (first time using fh)
I'm not super familiar with Firehose, it seems using these Cfn constructs is your best bet
doh… kk
@Dan Van Brunt We are planning to update the CDK version soon. What’s ur timeline on implementing the kinesis firehose?