https://serverless-stack.com/ logo
#help
Title
# help
n

Nick Laffey

11/19/2021, 3:45 PM
I’m getting an error when querying my
rds.ServerlessCluster
which does have `enableDataApi: true`:
Copy code
HttpEndpoint is not enabled for cluster PHO-115-iridium-backend-iridiumdb. Please refer to <https://docs.aws.amazon.com/AmazonRDS/latest/AuroraUserGuide/data-api.html#data-api.troubleshooting>
The docs it’s referring to suggest that data API is either not enabled or the DB has been renamed since it was enabled. I verified via the RDS console that the dataAPI is enabled. I don’t really know how/why the database would have been renamed as this occurs after kicking up a brand new stage which gets it’s own named database. I’m curious if anyone else has run into this or has any ideas? I’m going to disable and then reenable the data api via the console to see if it starts working again.
I might have figured it out… seems like my database cluster arn may be uppercased in some places and not in others.
Copy code
this.serverlessCluster.clusterArn
appears to be outputting with uppercase from my stage name but in the RDS console it’s lowercase
Found a github issue for this, however it was fixed/closed some time ago: https://github.com/aws/aws-cdk/issues/12795
f

Frank

11/19/2021, 11:25 PM
Hey @Nick Laffey, I think solution 2 suggested by Adam should work. Let me know if you get a chance to try it!
n

Nick Laffey

12/06/2021, 9:31 PM
@Frank thanks, yeah I just lowercased when passing into the clusterIdentifier field on
rds.ServerlessCluster
, that worked for me.
5 Views