Something happen with the latest version of SST? I...
# help
Something happen with the latest version of SST? I updated ( SST 0.57.4 , CDK 1.138.0)and ensured all cdks are same version. but can’t
yarn start
without error now.
Copy code
TypeError: Cannot read properties of undefined (reading 'Symbol(@aws-cdk/core.Stack.myStack)')
    at Function.of (/Users/me/Projects/idx/node_modules/@aws-cdk/core/lib/stack.ts:72:37)
    at lambdaAuthorizerArn (/Users/me/Projects/idx/node_modules/@aws-cdk/aws-apigatewayv2-authorizers/lib/http/lambda.ts:100:23)
    at HttpLambdaAuthorizer.bind (/Users/me/Projects/idx/node_modules/@aws-cdk/aws-apigatewayv2-authorizers/lib/http/lambda.ts:74:24)
Hm can you wipe node_modules and try it
I’m almost sure now that it something do to with we have sst listed as a dep on our constructs lib
and when I
yarn list @serverless-stack/resources
I get this….
but I have everything sst and cdk locked in my locally linked package
like does yarn link not pickup the symlinked package.json changes? (update versions of sst) ?
Otherwise how do you guess dev and test locally ?
do I need to add a
for sst in my consuming package.json?
I tend to yarn link everything
So even if I'm just working on resources I link core, cli, etc
It doesn't properly get the right stuff otherwise
sure… I’m only working on our own custom lib that deps sst. So I’m only linking that
and this usually works
but its not picking up the fact that I bumped up the version of the sst in my lib
Gah! Now I have
yarn start
working… but my function is given errors about packages that make no sense…. and I don’t believe we made any changes that would have done this.
@thdxr is that SST dev (live) erroring out.. or my actual function code? ☝️
super odd. I get this same error when I just simply
yarn build
There was a problem transpiling the Lambda handler
why does it look like its trying to compile the node_modules folder?
@thdxr Still dead in the water with this issue. Both @Camilo Bravo and I CAN reproduce the issue on both our machines • macOS: 12.0.1 • Node: 16.13.1 However, our pipeline works just fine • GitHub Actions • ubuntu-18.04 • Node: 16.13.1 And the issue seems to be coming from SST’s
file if you look above.
Tried scorched earth approach and deleted the whole repo folder and re-cloned. Still same error as above. Only local. Pipeline works fine.
CAN confirm this now has nothing to do with “latest” sst versions. We’re only talking about what has been working in our pipe/repo for days.
going to reopen a new thread with the latest for clarity.
Hi @Dan Van Brunt, it did not help after reverting back to
lemme join the other thread