https://serverless-stack.com/ logo
#sst
Title
# sst

Question

How can I disable linting in my TypeScript project using @typescript-eslint and sst.json?

Answer

To disable linting, you can add "lint": false in your sst.json file. It is also recommended to use a supported version of TypeScript (currently >=3.3.1 and <4.1.0) with @typescript-eslint to avoid potential issues.

t

thdxr

02/15/2021, 7:13 PM
Copy code
WARNING: You are currently running a version of TypeScript which is not officially supported by @typescript-eslint/typescript-estree.

You may find that it works just fine, or you may not.

SUPPORTED TYPESCRIPT VERSIONS: >=3.3.1 <4.1.0

YOUR TYPESCRIPT VERSION: 4.1.5

Please only submit bug reports when using the officially supported version.
f

Frank

02/15/2021, 7:14 PM
Yeah, we are thinking of adding an option to disable linting entirely.
Let me talk to the team in a bit and get back to you.
t

thdxr

02/16/2021, 1:50 AM
awesome thanks!
f

Frank

02/16/2021, 10:53 AM
@thdxr quick update.. we are working on the disable linting option. I will try to have something by later today. I will keep you posted.
t

thdxr

02/16/2021, 2:36 PM
awesome!
f

Frank

02/17/2021, 10:00 PM
Just released v0.9.4 with the ability to turn off lint. Also updated the
typescript-eslint
version to fix the above warning - https://twitter.com/ServerlessStack/status/1362151402437492745
To turn off lint, add
"lint": false
in your
sst.json
t

thdxr

02/18/2021, 1:49 AM
sweet thanks!
561 Views