When using sst start (haven't tried a deployed ver...
# sst
When using sst start (haven't tried a deployed version yet) after returning from a cron-triggered lambda I'm seeing the following error in the log:
Copy code
SyntaxError: Unexpected token n in JSON at position 0
    at JSON.parse (<anonymous>)
    at createStrictSyntaxError (/Users/rosscoundon/Documents/GitHub/omw-pso-be/node_modules/body-parser/lib/types/json.js:158:10)
    at parse (/Users/rosscoundon/Documents/GitHub/omw-pso-be/node_modules/body-parser/lib/types/json.js:83:15)
    at /Users/rosscoundon/Documents/GitHub/omw-pso-be/node_modules/body-parser/lib/read.js:121:18
    at invokeCallback (/Users/rosscoundon/Documents/GitHub/omw-pso-be/node_modules/body-parser/node_modules/raw-body/index.js:224:16)
    at done (/Users/rosscoundon/Documents/GitHub/omw-pso-be/node_modules/body-parser/node_modules/raw-body/index.js:213:7)
    at IncomingMessage.onEnd (/Users/rosscoundon/Documents/GitHub/omw-pso-be/node_modules/body-parser/node_modules/raw-body/index.js:273:7)
    at IncomingMessage.emit (events.js:412:35)
    at IncomingMessage.emit (domain.js:470:12)
    at endReadableNT (internal/streams/readable.js:1317:12)
Is something inside of SST expecting a JSON payload to be returned? I've always just returned void from these kinds of lambda
seems to be happening from within aws-lambda-ric I'm using v0.47.1
Really just a guess, but seems like it is coming from the websocket they turn on for debugging
I got this a lot last night, intermittently, and couldn’t figure it out.
Hm weird. Can you share your debug log with me
Sure, 2 mins