Thread
#secoda-support
    m

    modern-church-42962

    2 months ago
    Having Snowflake query problems today. I do see my tables in the catalog, but I'm unable to get a simple
    select
    working. If I try
    SELECT schema.table
    I get an error message like
    Failed to execute query (snowflake.connector.errors.ProgrammingError) 090105 (22000): 01a56791-0000-9ce8-0000-15ad29505862: Cannot perform SELECT. This session does not have a current database. Call 'USE DATABASE', or use a qualified name.
    If I add
    USE database
    above my select query, I get an error message like
    Failed to execute query (snowflake.connector.errors.ProgrammingError) 001003 (42000): 01a56794-0000-9ce8-0000-15ad29505e92: SQL compilation error:
    syntax error line 2 at position 0 unexpected 'SELECT'.
    Any guidance?
    e

    elegant-house-93198

    2 months ago
    You’ll have to run the following queries on the
    SECODA
    role (or other role you’ve used to connect to Secoda) on your warehouse and database @modern-church-42962
    GRANT USAGE ON WAREHOUSE "<warehouse>" TO ROLE SECODA;
    GRANT USAGE ON DATABASE "<database>" TO ROLE SECODA;
    m

    modern-church-42962

    2 months ago
    Thanks!
    We had done that, but got it sorted by setting up a default. Separately - query running permissions for editors aren't sticking - I click the checkboxes next to their names and hit "submit" - but if I navigate away and come back, the boxes clear (and they report not being able to run the queries)
    e

    elegant-house-93198

    2 months ago
    We’ve updated you to an Enterprise trial @modern-church-42962, let me know if you’re able to add editors now 🙂
    m

    modern-church-42962

    2 months ago
    I can add editors, but my editors can't run queries in documents - only admins can.
    e

    elegant-house-93198

    2 months ago
    I’m just going to DM you the workaround @modern-church-42962