I've been using a development Prisma server to bui...
# orm-help
j
I've been using a development Prisma server to build out a new app, and it has worked great! Now I'm trying to set up production servers, and I can not figure out how to configure them for Now (Zeit) without being wide open to the public — I tried using Prisma Cloud first, but I keep getting stuck on the "Create a new server" with a neverending loading spinner and an Apollo error in the console.
l
What's in your
prisma.yml
file?
j
I found the new docs after posting this, and they were helpful in explaining how things should work—but I’m finding that my managementApiSecret value is simply being ignored—or at least, I am specifying one and yet my deployment still seems to be wide open
I’ve followed this example fairly directly: https://github.com/develomark/prisma-now
and I only changed the user value in their example, to match the user in my actual database
l
Did you redeploy?
j
oh—maybe not…let me give that a go
I didn’t realize the deploy command made those settings active
that didn’t help anything…when I deployed to Now, it made the playground available at this URL: https://shuri-prisma-kqopyarpoc.now.sh/
(that’s hooked up to a test database with almost zero data)
but I can still query there without any credentials
I even tried hard-coding the values in to my .yml file, instead of having the
Dockerfile
drop them in via
sed
, and got the same result.
wait! nevermind…the deploy fixed it after all, I just didn’t notice the error the first time I ran it—once I got it to run successfully, I’m getting a “our token is invalid. It might have expired or you might be using a token from a different project.” response — yay! Might be worth putting something in the docs about how you need to do a
prisma deploy
before seeing any changes to the management API secret take effect
l
Awesome!