<@U5P82S230>: one more newbie question. is there a...
# prisma-whats-new
@agartha: one more newbie question. is there a way to create a local instance for offline development?
If you use the framework provided by graphcool here https://github.com/graphcool/framework there is a command "gc local up" which will let you create a local environment via docker
😎 1
👍🏻 1
type "gc local" to view all the commands available
Make sure you have docker installed first 🙂
You need docker and docker-compose.
👍 1
hey aren’t you the dude that wrote “fuck clojure” lol
this was referred to OP not you lol, i thought you wanted to know about the post
Nvm, it's late...
But I would like to say 🎉 @zcaudate for saying it 😄
😂 2
@Tavo yes. it cleared up quite a few things for me
@Kat thanks. I'll take a look at it
@agartha i was able to get the local graphcool cluster up and running, but i dont understand where to go from here. how do i run a playground against my local instance to check how things are working ? If i open http://localhost:60000 on my machine, it says resource not found.
any help would be appreciated 🙂
@rhishikeshj there is a command
look into that
@Tavo Thanks for your suggestion. But I dont actually have a function which i want to invoke locally. I just wanted to know how to do a deploy of a local graphcool project.
To anyone who is reading this, the way to actually fix this is start from a new project with
graphcool init && graphcool local up && graphcool deploy
This ultimately deploys the graphcool services locally and you can launch a playground against it. What I was doing was starting from a project which was exported from the Graph.cool console in the browser. Maybe there’s an extra step involved when deploying exported projects locally
@agartha @Tavo @Kat Is there a way to check out the graphcool project on another system and run it locally there ? Currently when i try to run an existing local deploy project, i get an error saying
<project-id> was not added to the <mailto:test@test.org|test@test.org> account
try "gc deploy -i"
it will let you choose a new deployment location
@zcaudate can you give this a try ?
@rhishikeshj cool
it worked